Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Nu-Relics Power Windows
American Auto Wire Hellwig Products IncPerformance Rod & Custom
Danchuk Catalog



Username Post: 1972 Nova Fuel Problem        (Topic#368648)
HandyAndy 
Newbie
Posts: 24

Loc: Iowa City, IA
Reg: 09-05-19
06-09-22 06:04 PM - Post#2842629    

Same car, 1972 Nova with a 454 four barrel carburetor. The engine will run for 20 or 30 minutes and then quit. A see through fuel filter is bone dry. After the car sits for a while, there's fuel visible in the filter and the engine will re-start. I thought I solved this by venting his 'vented' fuel cap, but the condition continues. Could a fuel pump act like that? Could there be debris in the fuel tank that creates an obstruction? An internal carburetor problem? We're running out of ideas, so I thought I'd run this by you for some troubleshooting directions.

Thanks!

HandyAndy


 


Tony1963 
Frequent Contributor
Posts: 1411

Loc: Orlando Florida
Reg: 07-09-18
06-11-22 10:52 AM - Post#2842711    
    In response to HandyAndy

No fuel in the filter sounds like an obstruction to me. You'll have to figure out if the obstruction is in the tank or the lines.

Use a hand held vacuum pump to see if you can draw fuel through the line and if not, see if you can pull it out of the tank.



People fear change because it threatens what they know, or what they claim to know.


 
wagonman100 
Site Ambassador
Posts: 15625

Loc: Baltimore, MD
Reg: 11-27-04
06-11-22 11:29 AM - Post#2842713    
    In response to Tony1963

Sounds like the pickup in the tank is getting blocked. If there is debris in the tank it will float on the gas and the pump creates suction while drawing fuel. Eventually the debris gets sucked into the pickup, which usually has a sock on it to prevent dirt from getting to the engine. Kind of a pre-filter. When the sock gets clogged, the engine stalls and no fuel comes through the line. Once the suction stops the debris will come off the sock and let fuel through again. If it was the in line filter it likely would not be dry when this happens. When it happens, disconnect the line from the tank and run a short line to a can of gas and see if the pump draws as it should. Mechanical pumps don’t draw too well, so having the can higher than the pump and the line primed would help. Be very careful and have a fire extinguisher handy. Things don’t usually go wrong when running the car from a gas can. But fires can happen and you want to be ready if it does.

Jay
Friends don’t let friends drive Fords.

1999 Silverado Z71 4X4 extra-cab short bed
1983 Malibu Fauxmad - tubbed
1978 El Camino Kustomized
1972 Monte Carlo
1957 210 handyman wagon
1957 Nomad sport wagon
1957 Cameo Carrier


 
HandyAndy 
Newbie
Posts: 24

Loc: Iowa City, IA
Reg: 09-05-19
06-13-22 02:45 PM - Post#2842866    
    In response to wagonman100

Thanks for your replies! We will try your suggestions. I'll circle back and let you know how we did.

Thanks again,

HandyAndy


 
HandyAndy 
Newbie
Posts: 24

Loc: Iowa City, IA
Reg: 09-05-19
06-26-22 06:38 PM - Post#2843416    
    In response to HandyAndy

We dropped the tank and it was absolutely clean. No problem with the pick-up tube or sock. The fuel line was unobstructed from the tank to the fuel pump. The fuel pump failed a vacuum test.

The new fuel pump solved the problem. Thanks for your help fellas!

HandyAndy


 


Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

230 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.142 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 12:14 AM
Top