Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Nu-Relics Power Windows
American Auto Wire Hellwig Products IncPerformance Rod & Custom
Danchuk Catalog



Username Post: Instrument language error        (Topic#366539)
Crusty66 
"9th Year" Gold Supporting Member
Posts: 428
Crusty66
Age: 61
Loc: Albany, eNZed
Reg: 11-04-12
09-28-21 12:05 PM - Post#2828192    

My cluster language keeps changing randomly & the trip meter keeps resetting all by itself.

Currently it displays in Spanish, sometimes French etc.

I guess this means I need to do the re-solder job on the board????

Steve
1966 Caprice 396 496 496mkII TH400
'03 Avalanche 1500 RHD


 
JLDT 
Member
Posts: 274
JLDT
Loc: Oregon
Reg: 03-31-05
10-13-21 07:50 PM - Post#2829125    
    In response to Crusty66

Sounds like - I recommend making sure you have a fine tip iron. I tried it with your simple cheap pencil type and found it to be too clumsy and had to get a finer tip to make things work better. I found a really good youtube video that showed what all you should re-solder when you are fully refurbishing, and I think he mentioned the language thing specifically in the video. I only did the pieces that I needed to when I was working on mine, which may come back to haunt me at some point.

Jordan

2004 Chev Silverado 2500HD 6.0L 4x4
2000 Oldsmobile Bravada
2011 GMC Acadia - NIGHTMARE


Edited by JLDT on 10-13-21 07:50 PM. Reason for edit: No reason given.

 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

178 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.129 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 12:26 PM
Top