Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Nu-Relics Power Windows
American Auto Wire Hellwig Products IncPerformance Rod & Custom
Danchuk Catalog



Username Post: Frustrated. Barely starts runs terrible        (Topic#365095)
Veryclere 
Gold Supporting Member
Posts: 43
Veryclere
Loc: N East Ohio
Reg: 12-13-20
05-03-21 06:42 AM - Post#2819197    

68 impala. 70 Monte Carlo 454. Gas tank cleaned. New sending unit. All flexible fuel line replaced. New fuel filters before and after new mechanical fuel pump. New vacuum lines. Holley 750 carburetor rebuilt. New battery. New battery cables. New starter. New plugs prior to carb rebuild. New dist cap and rotor. New ignition module. New coil.

Ran fair last Monday. Not great but at least running and squealing tires. My next step was alignment and front suspension checks until This weekend it barely starts and then runs terrible or barely runs at all.

Going to verify timing and check vacuum. Going to replace the plug wires. After that the only thing left to replace is the actual distributor. (That I can think of)

ANY help is appreciated. Truly frustrated and at a loss for what else to check.



 


59fins 
Member #212 "20th Year" Gold Supporting Member
Posts: 2440
59fins
Age: 60
Loc: Surprise Az USA
Reg: 04-07-00
05-03-21 06:00 PM - Post#2819229    
    In response to Veryclere

Just a thought?
2 fuel filters, could that restrict the flow?

Bill H.
67 SS




 
S10mk 
Newbie
Posts: 31

Reg: 01-03-19
05-04-21 05:38 AM - Post#2819250    
    In response to Veryclere

It's so hard to say with those symptoms, but I would start with some basic trouble shooting.
1. Do a compression check, it's a good place to start and you'll be able to see how healthy your engine is. While you're doing a compression check, inspect your spark plugs to see if their clean or fouled.
2. Take an extra spark plug and ground it to something, hook a plug wire up to it and start the engine. You'll only be running on 7 cylinders, but it's a good way to check for a nice crisp spark.
3. It almost sounds like you have a vaccum leak, with the engine running, spray some brake clean or carb cleaner around the carb. If the engine speeds up while you're spraying, then you have a vacuum leak in that area.
4. With the engine running, look down into the carb. If fuel is dripping or running out of the boosters, then either your float needs adjusted or you have some dirt in your needle and seat or somewhere else in the carb.
5. Look at your engine grounds. Your battery should have a good ground to the frame and to the engine. And like wise, your engine should be grounded to the frame and to the battery. Those grounds should be tight and free from corrosion.

Those are just some things to look at, hope this helps!



 
Veryclere 
Gold Supporting Member
Posts: 43
Veryclere
Loc: N East Ohio
Reg: 12-13-20
05-08-21 07:32 PM - Post#2819523    
    In response to S10mk

Thanks much for your advice! Worked all afternoon. Started with manually turning the crank to see if there is any play in timing chain; none noted, disty turns almost immediately.

Replaced spark plug wires. Bumped engine and watched for rotor to point at plug wire 1; mark on harmonic and rotor matched up close. Removed plug one and bumped engine to check for compression at TDC. Rotor points to plug wire 1. Checked coil wire for spark; looks good. Connected timing light to plug 1; good strobe. Checked positive side of coil, 12v.

NO START. Plenty of crank.

Retard disty. Nothing. Advance disty finally get back fire and fuel out of the carb to hood.

NO START

Replace ground straps from block to frame and firewall. Clean and re-install ground strap from disty to firewall. Cleaned and sanded all ground contacts. Remove ground strap from disty to valve cover (???).

NO START

Will learn how to test compression. And already cried uncle and called mechanic.

Would so very much like to fix this myself. I have no idea where to look next. Only thing not replaced is the distributor.



 
Rick Dorion 
"7th Year" Gold Supporting Member
Posts: 318
Rick Dorion
Loc: Accord, NY
Reg: 09-21-12
05-09-21 01:49 AM - Post#2819530    
    In response to Veryclere

So you have spark. When you look down the throat of the carb and move the linkage do you see a stream of gas shoot into the throat? I'd eliminate the filter before the fuel pump.

1967 Belair - LM7 5.3, Autogear M23Z, Global West, C5 brakes and rims.


Edited by Rick Dorion on 05-09-21 01:50 AM. Reason for edit: No reason given.

 
Veryclere 
Gold Supporting Member
Posts: 43
Veryclere
Loc: N East Ohio
Reg: 12-13-20
05-09-21 04:55 AM - Post#2819536    
    In response to Rick Dorion

Yes. Plenty of fuel. See it in primary and secondary.



 


Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

153 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.144 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 06:02 PM
Top