Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: Reproduction 53-54 horn ring        (Topic#364853)
alltak 
"13th Year" Silver Supporting Member
Posts: 289
alltak
Loc: dallas texas
Reg: 10-04-04
04-07-21 07:09 PM - Post#2817684    

A while back some posted a fix for the repop horn ring so that they would work correctly. Pretty sure it was here, but can't seem to find it. Anybody remember the post?

TIA Alltak



 


5354belair 
Newbie
Posts: 10

Loc: Eugene Oregon
Reg: 04-02-11
04-08-21 07:48 PM - Post#2817731    
    In response to alltak

I have a reproduction horn ring from a few years back and it worked fine. what is not working on yours. Nice build you have
Steve



 
alltak 
"13th Year" Silver Supporting Member
Posts: 289
alltak
Loc: dallas texas
Reg: 10-04-04
04-09-21 05:11 AM - Post#2817744    
    In response to 5354belair

Thank you. Really hope to be driving by summer...

It appears the mounting flange is too thick and when the screws get tightened down, and the horn will not move.

The post I am looking for, removed some material from around the mounting holes. It may have been a Facebook post.

I have not had a chance to really look at it yet. Hopefully have some time tonight.

Thanks



Edited by alltak on 04-09-21 05:12 AM. Reason for edit: No reason given.

 


Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

170 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.148 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 09:17 PM
Top