Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: Runs rough when accelerating        (Topic#364831)
Liberty Valance 
Contributor
Posts: 127
Liberty Valance
Loc: Euless,Texas
Reg: 07-21-14
04-05-21 06:09 AM - Post#2817510    

I have an upgraded dist from points to HEI 5 years ago.

Engine started running rough this last week when accelerating. Runs normal in Park or Neutral. Runs rough in gear sitting still also. Replaced plugs and the in-carb fuel filter today and no difference. Truck died on the street last weekend and I found a vaccuum hose had split on the end and fell off. Trying to restart I flooded carb and could not start for a while. This flooding may have caused an issue in the carb. The last rebuild was July 2017. Thinking I may need to rebuild again, not sure.

I have rechecked all vacuum lines, plug wires and all are good. Pulled dist cap and nothing bad found. Checked fuel lines and cannot find anything I can tell that is causing this. Would a bad ignition module cause this or possibly coil? I have had a no start due to the module before.


1974 Cheyenne 10 LWB STOCK 350 W/HEI /TH350 /AC/ 4 BBL Quadrajet
Mopar by Birth
Chevy by Choice


 
gchemist 
Member #271 Senior Chevytalk Moderator
Posts: 25408
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
04-05-21 09:47 AM - Post#2817521    
    In response to Liberty Valance

How old is the fuel pump? Do you have a timing gun? You can connect it to check for timing advance. Is the choke opening all they way?

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles
'08 GMC Acadia 3.6L SLE


 
Liberty Valance 
Contributor
Posts: 127
Liberty Valance
Loc: Euless,Texas
Reg: 07-21-14
04-05-21 10:28 AM - Post#2817523    
    In response to gchemist

Fuel pump is about 2 years old, it is an AC delco. Had auto store brand that did not last long so got the higher priced AC Delco. Haven't checked timing yet, but did disconnect vacuum for dist and engine acted just as usual. Will check timing. Truck does idle in Park normal even when revving there is no rough running I can tell.

1974 Cheyenne 10 LWB STOCK 350 W/HEI /TH350 /AC/ 4 BBL Quadrajet
Mopar by Birth
Chevy by Choice


 
bobb 
Super Senior Member
Posts: 5775

Loc: paradise
Reg: 09-05-03
04-06-21 08:06 AM - Post#2817586    
    In response to Liberty Valance

i would start from sqyare 1 with a tune up and compresion test

70 L camino, grampa engine, g-force 5 spd, road rage suspension. Pray first before all else fails.


 
sawyer 
"2nd Year" Gold Supporting Member
Posts: 34
sawyer
Loc: Long Beach, CA
Reg: 10-23-15
04-07-21 10:51 AM - Post#2817658    
    In response to Liberty Valance

Which model Q-jet do you run? I had similar issue at high rpm, was the pump in my E4ME which was a dual designed for off-road use vs the standard single pump.

Long Beach, CA
'85 350 K5
'89 318 Dodge W150


 
Liberty Valance 
Contributor
Posts: 127
Liberty Valance
Loc: Euless,Texas
Reg: 07-21-14
04-10-21 03:34 PM - Post#2817824    
    In response to sawyer

I have the R4-4MV carb.

UPDATE

I performed all the troubleshooting I could do with only having a carport and limited tools. Finally decided to take it to my tech and said my cam had finally worn down that is causing the rough running. He had discovered the #8 cam lobe was worn a few years ago when replacing the valve stem seals. It was worn and only raising rocker arm a little. He is in the process replacing cam. He is going to put in an Edelbrock Performer cam. He said it is the beefiest he could install without any other upgrades which is more than the stock one. Should be finished by next Friday.

1974 Cheyenne 10 LWB STOCK 350 W/HEI /TH350 /AC/ 4 BBL Quadrajet
Mopar by Birth
Chevy by Choice


 
gchemist 
Member #271 Senior Chevytalk Moderator
Posts: 25408
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
04-12-21 03:22 AM - Post#2817892    
    In response to Liberty Valance

Nice! Save the cam! Can you post a picture of it? Any plans to upgrade the intake? With everything off, a nice dual plane intake would help it breath better.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles
'08 GMC Acadia 3.6L SLE


 
Liberty Valance 
Contributor
Posts: 127
Liberty Valance
Loc: Euless,Texas
Reg: 07-21-14
04-12-21 01:56 PM - Post#2817918    
    In response to gchemist

  • gchemist Said:
Nice! Save the cam! Can you post a picture of it? Any plans to upgrade the intake? With everything off, a nice dual plane intake would help it breath better.



Don't have a pic now but did see it. That one lobe was almost completely round. There were others worn, of course, but not as bad. I think I will keep my original intake.

This is the cam going in.

https://www.summitracing.com/parts/edl-2102

I don't think it came from summit but found this first in my search. Maybe will have a little more kick, or a tap at least....LOL

1974 Cheyenne 10 LWB STOCK 350 W/HEI /TH350 /AC/ 4 BBL Quadrajet
Mopar by Birth
Chevy by Choice


 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

127 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 1.543 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 02:20 PM
Top