Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows





Username Post: my '08 trailblazer        (Topic#364410)
68impalass 
Newbie
Posts: 47

Loc: sydney, nova scotia , can...
Reg: 12-20-11
02-20-21 06:43 PM - Post#2814755    

hello....my trailblazer is having an issue . it wont activate the 4wd system . when i use the control knob to select a range most times it'll try to engage,but the lights will blink and it wont engage . also the service system light will come on . itll go into low range but thats it . ahybody familiar with whats going on? i'd really like to be able to get it to work right again .Thanks in advance



 




gchemist 
Member #271 Senior Chevytalk Moderator
Posts: 25375
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
02-21-21 05:21 AM - Post#2814775    
    In response to 68impalass

Welcome to the site. Unfortunately, I'm not familiar with Trailblazer 4X4s.
A search found this help information.
Go through the procedure.
Can you hear the actuator move? If it's moving, the module may be bad.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles
'08 GMC Acadia 3.6L SLE


 
68impalass 
Newbie
Posts: 47

Loc: sydney, nova scotia , can...
Reg: 12-20-11
02-21-21 09:29 AM - Post#2814787    
    In response to gchemist

the link will be very helpful.thank you very much



 
Shepherd 
Frequent Contributor
Posts: 2228

Loc: Lake George, NY
Reg: 11-11-15
02-21-21 01:38 PM - Post#2814811    
    In response to 68impalass

Lotta issues with the module, common problem.



Edited by Shepherd on 02-21-21 01:38 PM. Reason for edit: No reason given.

 
68impalass 
Newbie
Posts: 47

Loc: sydney, nova scotia , can...
Reg: 12-20-11
02-21-21 06:25 PM - Post#2814831    
    In response to Shepherd

do you mean the Transfer Case Encoder Motor? i'll hafta check that out .thanks



 
Shepherd 
Frequent Contributor
Posts: 2228

Loc: Lake George, NY
Reg: 11-11-15
02-22-21 08:31 AM - Post#2814866    
    In response to 68impalass

Yes and the dash switch was bad too.



 
gchemist 
Member #271 Senior Chevytalk Moderator
Posts: 25375
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
02-22-21 11:57 AM - Post#2814883    
    In response to Shepherd

Great, so it is working again?

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles
'08 GMC Acadia 3.6L SLE


 
68impalass 
Newbie
Posts: 47

Loc: sydney, nova scotia , can...
Reg: 12-20-11
03-02-21 05:59 PM - Post#2815442    
    In response to gchemist

not yet but soon . saving $$$$ first for parts



 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

162 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.063 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 04:33 AM
Top