Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows





Username Post: Engine & Transmission Control Problems, 2010 Equinox        (Topic#362526)
Burnbomber 
Member
Posts: 17
Burnbomber
Loc: Kansas City, Missouri
Reg: 03-17-03
09-10-20 08:04 AM - Post#2803192    

I've got a 2010 Equinox 2LT with 99.5k miles, and purchased in June, 2010. So, just over 10 years old.

Getting intermittent no power. It started on a 600 mile day with a harsh 5th to 6th (top gear) shift. Then, coming back it surged bad. I think it was power, no power, power, no power, etc. A few more miles down road, pull off to pee, got NO drive action. Would start, engine runs fine but no torque thru tranny. Shifted around, turn off, on, etc. would sometimes work, sometimes no action.

One time, shifting forward to reverse, it gave a MASSIVE clunk but then I had drive again.

Shifting was wonky, too. It would hold the low gear too long, hold revs up, just not right.

So, we're finally here and getting off highway ramp, pull up to the light and wait. My turn to go, hit the gas but NO wheel turns. Stuck there for 5 minutes till it "reset" and I had drive again. Slammed the hood down, got it at house and parked, unloaded.

Had NO engine light during this. Driving it to the dealer last night, it worked great until I pulled into his shop, then reduced torque. I had drive, brakes would hold it but gas would cause it to race, torque thru wheels was only partial.

So, it got parked, I read the warranty, then moved it to the dealer. The drivetrain warranty is 8 years, 100 k miles. We'll see what they find, and how much for them (expect some $$ warranty consideration) and me??

2010 Equinox, 2LT, 2.4 6-speed auto. white with brownstone leather and great Panasonic sound system

89 Chevy Celebrity / Iron Duke / gone to the pull apart in the sky.


Edited by Burnbomber on 09-10-20 09:10 AM. Reason for edit: No reason given.

 




Burnbomber 
Member
Posts: 17
Burnbomber
Loc: Kansas City, Missouri
Reg: 03-17-03
09-11-20 09:07 AM - Post#2803248    
    In response to Burnbomber

5 years, not 8

2010 Equinox, 2LT, 2.4 6-speed auto. white with brownstone leather and great Panasonic sound system

89 Chevy Celebrity / Iron Duke / gone to the pull apart in the sky.


 
gchemist 
Member #271 Senior Chevytalk Moderator
Posts: 25255
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
09-21-20 11:33 AM - Post#2803968    
    In response to Burnbomber

Does it have any transmission codes? My Acadia has a 6T75. Codes P0877 and P0989 were present. Shifting was odd. I repaired the TECHM myself. A simple $35 kit was easy to install.
Pictures are availble.

Since the repair, shifts are better and smooth. No clunking. Broken seals are common for 6T75 and 6T70 transmissions.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles
'08 GMC Acadia 3.6L SLE


 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

159 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.103 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 06:46 AM
Top