Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: Any photos of splash pan for 60 V8 with power steering?        (Topic#361529)
Eth727 
Contributor
Posts: 329
Eth727
Loc: San Diego
Reg: 04-17-19
06-25-20 05:59 PM - Post#2797201    

I need a pic of what I'm missing. I have a 60 V8 with power steering. I think it's called a splash pan.



 


PLS 
"8th Year" Silver Supporting Member
Posts: 1562
PLS
Loc: Smyrna, Georgia
Reg: 06-07-12
06-25-20 08:47 PM - Post#2797211    
    In response to Eth727

At some point GM discontinued using the engine shield and my understanding is because it was creating overheating in the engine compartment. These are the pieces that I have but I haven't reinstalled them as of yet and not sure that I will. The power steering hose bracket was attached to the shield and when they discontinue the shield the new bracket was attached at the steering box using the box bolts. This is the page on the shield from the assembly manual. Hope that this helps. Lamar

Attachment: IMG_0133.JPG (113.59 KB) 1 View(s)




Attachment: IMG_0134_-_Copy.JPG (939.06 KB) 1 View(s)




Attachment: IMG_0135.JPG (1023.71 KB) 1 View(s)




Attachment: engine_shield.jpg (1.29 MB) 1 View(s)






Edited by PLS on 06-29-20 07:07 AM. Reason for edit: Corrected hose bracket location

 
ragtp66 
Contributor
Posts: 902

Reg: 12-09-07
06-25-20 09:23 PM - Post#2797217    
    In response to Eth727

Someone else may correct me if I am wrong but I thought the splash pans were discontinued after 1959.

Toys:
1958 Impala 2dr Hardtop Under Construction
1966 Chevelle Malibu Convert M20/350 Aztec Bronze
1987 Sea Ray Pachanga 22
2002 Cadillac Escalade EXT Parts chaser
2007 Trailblazer SS -gone and missed


 
Eth727 
Contributor
Posts: 329
Eth727
Loc: San Diego
Reg: 04-17-19
06-25-20 11:35 PM - Post#2797223    
    In response to ragtp66

Yeah so I had a splash pan installed on mine. I just got my car back from the body shop and noticed it was missing. Unfortunately it's now in Mexico and I probably won't get it back. I don't remember what it looked like but I know it covered the PS hoses because I had to remove the panel to get it.
I was going replace it because I don't like missing parts but it might be okay without it?



 
62BillT 
"18th Year" Silver Supporting Member
Posts: 5864
62BillT
Loc: Moneta, VA
Reg: 09-24-01
06-26-20 12:23 PM - Post#2797243    
    In response to ragtp66

  • ragtp66 Said:
Someone else may correct me if I am wrong but I thought the splash pans were discontinued after 1959.



There were on both the '59 and '60. The way I understand it is they made 2 kinds. One for both the 235-6 and the 348 and one for the 283.

Not sure if it was for the whole year or not in '60 and also heard that they produced a bulletin on them, as PLS has indicated.


Member:
-National Impala Association
-Vintage Chevrolet Club of America


 
Eth727 
Contributor
Posts: 329
Eth727
Loc: San Diego
Reg: 04-17-19
06-26-20 03:02 PM - Post#2797253    
    In response to 62BillT

Since Lamar doesn't have his on and there was a bulletin about cancelling them, maybe I should leave it off especially if it keeps the car cooler. What do you guys think? Does anyone else have them on their 1960's.



 
62BillT 
"18th Year" Silver Supporting Member
Posts: 5864
62BillT
Loc: Moneta, VA
Reg: 09-24-01
06-27-20 11:30 AM - Post#2797304    
    In response to Eth727

If I had a '59 or '60, I wouldn't put a pan on either, especially if you drive it a lot in hot weather.

Member:
-National Impala Association
-Vintage Chevrolet Club of America


 
Eth727 
Contributor
Posts: 329
Eth727
Loc: San Diego
Reg: 04-17-19
06-27-20 05:47 PM - Post#2797336    
    In response to 62BillT

So I take it that 61-on nobody used them?



 
PLS 
"8th Year" Silver Supporting Member
Posts: 1562
PLS
Loc: Smyrna, Georgia
Reg: 06-07-12
06-27-20 07:42 PM - Post#2797345    
    In response to Eth727

  • Eth727 Said:
So I take it that 61-on nobody used them?


I'm far from being an expert on the subject but I think that you would be safe in assuming that.





I don’t remember having a heating problem with the shields on but that was 40+ years ago and I can’t remember what I did this afternoon so I’m not going to reinstall them.

Here is a topic that I posted https://www.chevytalk.org/fusionbb/showtopic.php?t... and you can see in the picture that Jalapeno shared of the bracket that was used without engine shields installed.
You can see how neat that one looks and how mine sort of looks messy without the bracket.

I am going to try and find that bracket and install it. Jalapeno is the resident expert on power steering. Hope this helps. Lamar


Attachment: IMG_0142.JPG (722.01 KB) 2 View(s)




Attachment: IMG_0143__2_.JPG (727.85 KB) 0 View(s)


Is this bracket still installed on your car?




 
Eth727 
Contributor
Posts: 329
Eth727
Loc: San Diego
Reg: 04-17-19
06-27-20 10:35 PM - Post#2797351    
    In response to PLS

Yes I still have the PS bracket. It's so weird you don't have oil dripping underneath your car.



 
Verne_Frantz 
Member #574 "61-64 Subject Matter Expert"
Posts: 5773
Verne_Frantz
Loc: Hightstown,NJ USA
Reg: 08-22-00
06-28-20 06:51 AM - Post#2797360    
    In response to Eth727

Correct. Used in '59 and part of '60. None in '61.
The 6cyl & 348 are the same because of the longer oil pan (deeper notch in the pan).

Verne



 
PLS 
"8th Year" Silver Supporting Member
Posts: 1562
PLS
Loc: Smyrna, Georgia
Reg: 06-07-12
06-28-20 06:52 AM - Post#2797361    
    In response to Eth727

  • Eth727 Said:
Yes I still have the PS bracket. It's so weird you don't have oil dripping underneath your car.


I shouldn't say this because it will probably happen now but I don't have any oil leaks but I do have a leak from the old "glide" transmission





Attachment: IMG_0147.JPG (70.86 KB) 0 View(s)


This is after being parked about 2 1/2 weeks. I have to keep the drip pan under it.




 
Jalapeno 
Member #252
Posts: 9855
Jalapeno
Loc: The Republic of Texas
Reg: 04-30-00
06-28-20 10:01 AM - Post#2797370    
    In response to Verne_Frantz

  • Verne_Frantz Said:
Correct. Used in '59 and part of '60. None in '61.
The 6cyl & 348 are the same because of the longer oil pan (deeper notch in the pan).

Verne



^^What Verne said.^^

Jalapeno


 
Eth727 
Contributor
Posts: 329
Eth727
Loc: San Diego
Reg: 04-17-19
06-29-20 09:39 PM - Post#2797500    
    In response to PLS

Hey did someone spill red wine?



 


Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

302 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.09 seconds.   Total Queries: 20   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 08:11 AM
Top