Danchuk Catalog Classic Industries
American Auto Wire
Classic Performance Products
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows




Username Post: electrical problem        (Topic#361213)
larrybrowningmauldin 
Contributor
Posts: 429
larrybrowningmauldin
Loc: New Braunfels,TX
Reg: 08-16-05
05-31-20 05:53 PM - Post#2795345    

I come to this forum because it gives the BEST help(mechanical, electrical, and sometimes spiritual) for my 1958 Corvette. The problem that I've had for years but haven't taken the time to solve...the right turn signal, front and back do not turn ON.

Driver side (left)
-brake OK
-parking front & rear OK
-left turn OK

Passenger (right) Violet wire
-brake OK
-parking, front and rear OK
right turn problem
a. no front turn signal
b. no rear turn signal
c. no brake light
d. When the brake lights are ON,with right turn lever up for right turn,right brake light turns OFF. When the turn lever is returned to center position, the brake light turns ON again.
Could this be the blasted/blessed switch?

Thanks for considering problem, Larry





 


acardon 
Ultra Senior Member
Posts: 11393
acardon
Loc: DFW TEXAS
Reg: 03-25-05
06-01-20 05:59 AM - Post#2795372    
    In response to larrybrowningmauldin

Yes, that's most likely the turn signal switch.

Don
66 Corvair (driving)
57 2dr HT (driving)
56 2dr HT (waiting to be restored)


 
larrybrowningmauldin 
Contributor
Posts: 429
larrybrowningmauldin
Loc: New Braunfels,TX
Reg: 08-16-05
06-01-20 06:07 PM - Post#2795428    
    In response to acardon

Thank you for the answer. When posting, I told my wife that either ACARDON or DZAUTO would have the answer.



 
larrybrowningmauldin 
Contributor
Posts: 429
larrybrowningmauldin
Loc: New Braunfels,TX
Reg: 08-16-05
06-08-20 11:31 AM - Post#2795889    
    In response to larrybrowningmauldin

Good news. It wasn't the sliding switch. I skipped a step in the previous troubleshooting. The passenger side front "parking " light worked, but I didn't check the bulb itself. The "turn" filament was fried with black residue inside the glass. I should have checked that component FIRST. Aged rookie! Thanks again.



 


Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

376 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.125 seconds.   Total Queries: 15   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 03:52 PM
Top