Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: 95 5.7 Tbi Suburban runs bad        (Topic#359442)
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-11-20 10:11 AM - Post#2784183    

Hi all,

I have a 1995 Suburban with a 5.7 and Tbi and for a while I have been chasing down a hesitation issue with little success. So far I have replaced spark plugs , wires , distrubuter cap and rotor , fuel filter and egr valve all withing the last 15000 miles. These changes maybe made a slight change to performance but it still hesistates bad. I have also pulled codes from it but no codes come up. I have also checked live data with the scan tool for the 02 sensors and all seems to be functional.The egr valve was not holding preassure too, so i changed that , but still not completely solved. Finally last week , i bought an adapter to test the fuel preassure at the TB and found that when its idleing it is around 9 psi and when i give it some gas underload (in gear) it drops to about 5-6. I know these early tbi systems run at low preassure but is this normal for it to drop that low ? Let me know your toughts. If not what would be your next steps ? Fuelpump? Regulator? Thank you all for your time. Anton



 
CowboyTrukr 
"8th Year" Silver Supporting Member
Posts: 4330
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
01-11-20 12:54 PM - Post#2784190    
    In response to 95tbisuburban5.7

Even though 9-13 is the factory fuel pressure spec, most of us have found that nothing less than 10 is best.

Change your pump.

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD
‘87 GMC S15 SCLB 4.3 Auto - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
Shepherd 
Frequent Contributor
Posts: 1918

Loc: Lake George, NY
Reg: 11-11-15
01-11-20 12:59 PM - Post#2784191    
    In response to 95tbisuburban5.7

Under load the fp should increase to about 13psi, not drop, clogged fuel filter, bad fuel pump, or pressure regulator in the throttle body. BTW welcome to CT. Try to pinch off the return line, may not be able to if all metal. If the pressure does not go up, pump is bad.



Edited by Shepherd on 01-11-20 01:01 PM. Reason for edit: No reason given.

 
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-11-20 05:56 PM - Post#2784210    
    In response to Shepherd

Ok thats what I thought, ill try pinching it off and see what happens, thanks for your input.



 
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-11-20 05:58 PM - Post#2784211    
    In response to CowboyTrukr

Ok thats good to know thank you




 
65_Impala 
Very Senior Member
Posts: 4375

Reg: 12-29-02
01-11-20 05:59 PM - Post#2784212    
    In response to 95tbisuburban5.7

Fuel pressure is too low. around 11-13psi would be better.

Fuel pressure should not change with load. There is nothing in a TBI system which can change pressure depending on engine load.



 
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-11-20 06:11 PM - Post#2784213    
    In response to 95tbisuburban5.7

Ok , sounds like I need a pump then, what brand would you guys recommend ? What seems to be the best ? Thanks , Anton



 
bowtie44s 
Valued Contributor
Posts: 4258
bowtie44s
Age: 37
Loc: wv
Reg: 08-29-12
01-11-20 08:53 PM - Post#2784220    
    In response to 95tbisuburban5.7

Definitely time for a pump. Delphi is probably the best brand but AC Delco is good too. I wouldn't get anything besides one of those two.

I find it way easier to slide the bed back than drop the tank. 8 bolts and you can work on it at waist level and it doesn't matter if your tank is full.

Jeff

'88 Chevy K3500, aluminum head roller cam 511in³ stroker 10.5:1 compression, 96 NV 4500, 94-98 grille, 305/70-16 (33x12) BF Goodrich KM2s, 91 cluster swap


 
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-12-20 06:59 AM - Post#2784235    
    In response to bowtie44s

Ok ill go with one of those then. Ill have to drop the tank since im on a suburban platform. Shouldnt be too bad tho. Thanks Anton



 
CowboyTrukr 
"8th Year" Silver Supporting Member
Posts: 4330
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
01-12-20 09:08 AM - Post#2784247    
    In response to 95tbisuburban5.7

There’s a static ground strap from the tank to the body that sits next to the filler. 7mm screw if I recall correctly. Be careful to find it and remove it before you drop the tank. I didn’t when I first pulled mine. The fuel pump sending unit ground is on the top of the frame rail right near the harness plug. 13mm machine screw. It holds the harness plug in place.
15mm tank strap bolts.

You may find it easier to release the front tank mount by just removing the four nuts from the studs that go through the side of the frame.

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD
‘87 GMC S15 SCLB 4.3 Auto - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-12-20 09:41 AM - Post#2784249    
    In response to CowboyTrukr

Ok thats good to know thanks for the pointers ill let you know how it goes -Anton



 
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-18-20 08:06 AM - Post#2784585    
    In response to 95tbisuburban5.7

Hi all, just put the new fuel pump in it and I immediately noticed a difference. It fires up much faster now , the hesistation is gone and it runs great. Thanks for all your help. -Anton




Edited by 95tbisuburban5.7 on 01-18-20 08:07 AM. Reason for edit: No reason given.

 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

227 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.234 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 09:10 PM
Top