Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: power door locks not working,        (Topic#359181)
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-20-19 04:16 PM - Post#2782572    

On my 97 Suburban, when I started it up, the doors all locked as usual. I hit the unlock button on driver door and the locks automatically went back down to lock position. Did this a couple times. I manually unlocked passenger side for my wife and drove to store. When I got back in the truck, the door lock switch was dead. Tried the door lock switch on passenger side and it was dead too. The 20 Amp fuse is good so it is something else. My next step will be to take off driver door panel and check the switch to see if it is getting power and if it the switch contacts are working. Because both sides did not work I thought fuse. No I am not sure but to check power to the both switches. Anyone have any ideas what it could be besides a broken power or ground wire?

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
12-20-19 07:54 PM - Post#2782583    
    In response to baswm

Does this Sub have a car starter/keyless entry?
Almost sounds like a issue with that.
Especially if you say they are relocking like that.

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-21-19 06:09 AM - Post#2782599    
    In response to rockfangd

It does not have the remote start. It has the key fob to unlock the door but I have not used that in ages. Tomorrow I hope to remove the driver side window/door lock switch and see if I have voltage going to the switch part. I see a relay in schematic for the door lock Relay (behind center of dash). Wondering if that could be bad as well. Might replace it first because relays are a cheap part.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


Edited by baswm on 12-21-19 06:33 AM. Reason for edit: No reason given.

 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
12-21-19 09:53 AM - Post#2782614    
    In response to baswm

Is it factory keyless entry? or add on
It could be the lock switch but the one on the other side should work.
Could be a relay but rarely do I find that to be the cause. Worth a shot though.
In thinking now I suggest you check the harness between the cab and the door. (driver door).
I would not be one bit surprised if you have broken or frayed wires inside the rubber loom.
Opening and closing the door fatigues the wires over time causing them to break

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-22-19 05:11 AM - Post#2782652    
    In response to rockfangd

It has the key fob where you can open and close the door with the push of a button. I am not sure if it was factory or add on since it is part of the security system that was added on.

I will check for broken wire as you suggest. I never had an issue with a broken wire there in all the vehicles I have owned. I ordered the relay. Surprised at the cost. When it gets here I will swap it out and go from there. Be nice to get some warmer weather when I do the work on it.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
someotherguy 
Senior Moderator
Posts: 29061
someotherguy
Age: 49
Loc: Texas
Reg: 08-01-03
12-22-19 08:51 AM - Post#2782663    
    In response to baswm

I've seen some aftermarket alarm installs where they added relays for the door locks although the Suburban already has a relay from factory, so the relays are redundant/unnecessary. In my case where symptoms were very similar, they had put the relays in the cavity behind the driver side kick panel, and over the years the relays had gotten wet and corroded internally, locking them "on" which caused issues with the door locks. The factory relay was WARM when I found it under the dash above the transmission hump. Not good! Easy fix though.

Richard

06 Silverado ISS / 06 Silverado SS / 06 300C SRT8


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-27-19 07:15 AM - Post#2783018    
    In response to someotherguy

The new relay came in. Two questions. Is the old relay mounted with a plastic push pin that I should just be able to pry off like one on the door panels? Second question. The flat connector going to the old one. How does it come loose? I do not want to break it. Looks like there is a gray lock bar maybe that needs to be pulled out from the connector before pulling out but I cannot tell for sure. I do not want to break anything in case this is not the issue.

The relay I ordered was an AC/Delco. There is a cheaper one made by Doorman/BWD that looks exactly like what is mounted. That will be in tomorrow. It has the white plastic push pin so I am going to pry out old one and get a better look at how the connector plugs in and will hopefully unplug and plug in the new one and see if door locks work. Then I will look for broken wire in the door.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


Edited by baswm on 12-27-19 08:36 AM. Reason for edit: No reason given.

 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-30-19 02:06 PM - Post#2783235    
    In response to baswm

Just an update. It was a PITA to remove the connector from the old relay and put in the new replay. No change. At least I can rule that part out. When power is removed and reconnected the door locks automatically power lock in the lock position. Then the driver side and passenger side power door lock switch does nothing. Will not lock or unlock. I have to do it manually. Next step will be to remove the driver side door switch and test it. Check if it is working as designed with an ohm meter.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
12-30-19 05:56 PM - Post#2783253    
    In response to baswm

There is a short somewhere.
Either a switch, or more likely a aftermarket RKE or remote start with keyless entry module.
I assume you are having battery drain issues as well.
If it has any aftermarket RKE I would simply unplug it. If you unplug it and the locks work again then you know that was the cause.
If the problem is still occurring then that is not the issue.
More than once I have seen a shorted ADD on Keyless entry short and do things like what you describe

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-30-19 06:08 PM - Post#2783254    
    In response to rockfangd

It does not have remote start.
It does have remote unlock. If it is factory or not I could not tell you since I am not the original owner. The battery gets drained if it sits for a week without being started which I agree it sounds like something is shorting and draining the battery. The battery is ten years old and could also just be going bad. I will add more as I learn more about it so in case someone else has this issue, they can learn from what I found.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
12-30-19 06:30 PM - Post#2783257    
    In response to baswm

can you please post a pic of the remote?
I can tell for sure

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-31-19 09:30 AM - Post#2783309    
    In response to rockfangd

I joined as a silver member so once they change my profile, I should be able to post a photo.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
12-31-19 09:42 AM - Post#2783311    
    In response to baswm

Ok cool.
Worth every little bit

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
12-31-19 03:40 PM - Post#2783340    
    In response to baswm

The black widow fob came is for the security system. I use the other one but I need to replace the battery. Rarely do I need to lock the doors. Nothing to steal.

Attachment: Keyfob.jpg (696.12 KB) 3 View(s)




Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
12-31-19 04:56 PM - Post#2783345    
    In response to baswm

Ok so the one on the left is the oem one.
The one on the right is the one I question.
Does it utilize the lock and unlock function?
If you can unplug it to at least see if the problem disappears that may help you

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
01-01-20 08:19 AM - Post#2783391    
    In response to rockfangd

The FOB worked for locking and unlocking the doors last time it tried it couple years ago. It is in the drawer with the other spare vehicle keys. I ordered new power windows and when it comes in, I will pull the panel and look at all the wiring for shorts/opens. Do it all in one swoop. Seems lately everything has been fighting me and the components look like wreck it ralph was trying to do something. I need to find a new driver side power window benzel since three of the tabs are broken off. Nothing holds it down really.


Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
01-01-20 08:24 AM - Post#2783393    
    In response to baswm

Ok.
That security/keyless module should be under the dash on the left side. I figure it will be easy to find. A black module hanging with wires going in different directions.
I would start there.
I cannot tell you how many times I have had issues from fatigued units, and judging by that fob that was put in when the truck was new or close to it

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
01-10-20 09:14 AM - Post#2784122    
    In response to rockfangd

I bought a new battery since the one that I had was ten years old. Something is draining the new battery that I have not found yet. I put new driver door window/door lock switch. Nothing was shorted in the old one. I can hear the new relay click when I press door lock from either door.

I put new battery in keyfob but it does nothing.

I will look for the black module dangling underneath on the left side so see if something is obvious. Do you have any suggestions on what to look for?

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
01-10-20 06:07 PM - Post#2784155    
    In response to baswm

Ok
Try this first for your oem fob (3 button)
Hold the lock and unlock buttons for 3 seconds to resync the fob.
If that does not work here is a useful video
https://youtu.be/iRqP5wFcghY

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
01-14-20 03:39 AM - Post#2784365    
    In response to rockfangd

I put new battery in the fob and will try it when I get home. The lock or unlock button did not do anything. I pulled the 20 amp fuse (#13) to see if that circuit is draining the battery. I will try to start it up today to see if the battery is holding charge after putting fuse back. Then I will hold the lock and unlock buttons as you mentioned to resync FOB. I have too many projects going on at the same time so this is taking me longer than I thought it would. I do appreciate your inputs.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
01-15-20 08:17 AM - Post#2784428    
    In response to baswm

My battery was dead so I put the 20 amp fuse back in the circuit #13. I have the charger on the battery and while doing so, I took the FOB and held the unlock and lock buttons for several seconds and it was programmed. I hit the lock button and hear the relay under the dash click. The actual door locking actuators do nothing. As soon as I had charger attached to battery and on, the door locks all went into lock position.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
01-15-20 06:27 PM - Post#2784452    
    In response to baswm

Ok great on the fob.
My next step would be that aftermarket keyless entry/ alarm
Just unplug it.
That could be what is killing your battery as well

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
01-16-20 05:27 AM - Post#2784469    
    In response to rockfangd

It will be fun figuring out which harness is which. Will try to get to it over the weekend weather permitting.

Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
01-16-20 07:13 PM - Post#2784510    
    In response to baswm

Unplug them right from the module.
The unit will likely be hanging somewhere under the driver side of the dash.
Will look out of place and have plugs on multiple sides

Old School GM fan FOREVER


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
01-21-20 09:46 AM - Post#2784809    
    In response to rockfangd

I had time to look Saturday and of course, cold and sleeting so I did do much. I noticed this yellow harness and thinking this looks after market. Will undo it and see where it goes.

Attachment: under_dash.jpg (361.2 KB) 1 View(s)




Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
someotherguy 
Senior Moderator
Posts: 29061
someotherguy
Age: 49
Loc: Texas
Reg: 08-01-03
01-21-20 10:23 AM - Post#2784812    
    In response to baswm

Don't mess with that - it's yellow as a warning that those are airbag-related circuits!

Richard

06 Silverado ISS / 06 Silverado SS / 06 300C SRT8


 
baswm 
"2nd Year" Silver Supporting Member
Posts: 113
baswm
Loc: maryland
Reg: 12-22-03
01-21-20 10:50 AM - Post#2784814    
    In response to someotherguy

Thanks for the heads up. I will not mess with the yellow harness.


Bill
1966 Chevrolet Impala convertible
1997 GMC Suburban K1500 4x4
2001 Chrysler Town and Country
2007 Dodge Charger R/T


 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 2855
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
01-21-20 06:31 PM - Post#2784848    
    In response to baswm

Yes that is the Airbag.
What is the harness to the left in the picture though.
Possibly ziptied in place.
The module itself is what you are looking for.
Likely not bolted in place, but rather ziptied or hanging from something

Old School GM fan FOREVER


Edited by rockfangd on 01-21-20 06:32 PM. Reason for edit: No reason given.

 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

381 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.153 seconds.   Total Queries: 18   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 02:28 AM
Top