Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: Warning lights help needed please!!        (Topic#359114)
Willow 
Contributor
Posts: 180

Reg: 05-25-12
12-12-19 09:59 PM - Post#2782042    

Help Needed Please!!!
2012 Silverado 1500 crew cab 5.3. Was slowing down and skid control light came on dash and said skid control/Stabltrax off? Thought something in central counsel hit the switch located there but no. Everything acting normal but now have warning lights on dash. Checked ABS fuse, it’s Okay. Can’t reset by pushing on/off switch to clear lights.
Get message to check stabletrax system now upon starting truck and dash warning lights stay on??
Question: Is Truck Safe To Drive???

Can I disconnect battery a few minutes and try to reset???
Thanks in advance for any help. With wife seriously ill I just can’t afford a big repair bill. Hopefully truck is safe to drive 🤞



 
Shepherd 
Frequent Contributor
Posts: 1908

Loc: Lake George, NY
Reg: 11-11-15
12-13-19 04:35 AM - Post#2782053    
    In response to Willow

Really no quick fix here, you need to have it scanned for abs/stabilitrack codes. Usually when this happens the abs is disabled but the brakes should work OK.



Edited by Shepherd on 12-13-19 04:36 AM. Reason for edit: No reason given.

 
bobb 
Super Senior Member
Posts: 5517

Loc: paradise
Reg: 09-05-03
12-13-19 10:42 PM - Post#2782111    
    In response to Willow

should be safe to drive. get a $50 scanner, its worth it. nowadays gotta scan evting. had a guy come in with a trans problem that was caused by an engine temp sensor.

70 L camino, grampa engine, g-force 5 spd, road rage suspension. Pray first before all else fails.


 
Willow 
Contributor
Posts: 180

Reg: 05-25-12
12-14-19 01:09 PM - Post#2782145    
    In response to bobb

Thanks for the replies. On my way to get checked out, lights all went out by themselves. My Chevy dealer said probably a "Soft Code" error,don't worry about it. Everything working as it should. Thanks Again.



 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

240 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.264 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 09:39 PM
Top