Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: 4L60E Rebuild losing its mind.        (Topic#358729)
94 TransAm 
Poster
Posts: 1

Reg: 11-05-19
11-06-19 04:18 PM - Post#2779687    

I am semi old so I have alot of TH350 and 400 rebuilds under my belt but Ive only done 1 700 and 2 4L60s so Im a bit short on electronic tranny knowledge.
The story goes My step son decided to "try" to make it home when his tranny ran out of fluid. We all know how that ended. Anyway I had a spare 60 I got with a truck I bought so while he drove to work in 2nd gear I built the other and when it was ready I swapped them. I dont like building trannys I know nothing about but you know.

So I built it and it went fine, no issues but the break down gave me 2 fried clutch packs and a smoked rear planet.

So I put it in and I have no reverse at all. I have all forward gears but no lock up and all forward gears slip past half throttle. I can also feel the band chatter when it engauges.

I obviously have a low pressure issue, my question is could the pressure solonoid cause all this or do I have other issues?

I had no issues at all with the 700 or the other 60 I did so I feel semi sure all the internals are right and the pump was fine.

Any thoughts?



 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

94 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.169 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 01:00 AM
Top