Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: Blower fan not working        (Topic#358720)
Eth727 
Silver Supporting Member
Posts: 236
Eth727
Loc: San Diego
Reg: 04-17-19
11-05-19 02:33 PM - Post#2779617    

Anyone know how to get the blower fan to work?



 


Chair City 
Contributor
Posts: 493
Chair City
Loc: Thomasville, NC USA
Reg: 01-24-04
11-05-19 02:40 PM - Post#2779618    
    In response to Eth727

Do you have 12 volts at the blower terminal? If not check the fuse.

1960 Impala Spt. Cpe. Now in my son's garage


 
Eth727 
Silver Supporting Member
Posts: 236
Eth727
Loc: San Diego
Reg: 04-17-19
11-05-19 04:22 PM - Post#2779629    
    In response to Chair City

No



 
Chair City 
Contributor
Posts: 493
Chair City
Loc: Thomasville, NC USA
Reg: 01-24-04
11-06-19 12:04 PM - Post#2779679    
    In response to Eth727

Check for 12 volts at both ends of heater fuse with ign. switch on

1960 Impala Spt. Cpe. Now in my son's garage


 
Eth727 
Silver Supporting Member
Posts: 236
Eth727
Loc: San Diego
Reg: 04-17-19
11-12-19 11:54 AM - Post#2780046    
    In response to Chair City

There's no power going to the heater fuse.



 
Chair City 
Contributor
Posts: 493
Chair City
Loc: Thomasville, NC USA
Reg: 01-24-04
11-12-19 02:39 PM - Post#2780061    
    In response to Eth727

Does everything else work,lights,horn,signals? Will engine start and run?

1960 Impala Spt. Cpe. Now in my son's garage


 
ragtp66 
Contributor
Posts: 814
ragtp66
Reg: 12-09-07
11-12-19 06:03 PM - Post#2780073    
    In response to Eth727

Quick test runner a jumper from battery Positive to the stud where the power wire connect if it does not go then your motor is kaput or possible just stuck. Pull it off the car and see if you can turn it by hand. Sometimes they will just surface rust from condensation and sitting and all it takes is working it free by hand and then try it again.

Toys:
1958 Impala 2dr Hardtop Under Construction
1966 Chevelle Malibu Convert M20/350 Aztec Bronze
1987 Sea Ray Pachanga 22
2002 Cadillac Escalade EXT Parts chaser
2007 Trailblazer SS -gone and missed


 
Eth727 
Silver Supporting Member
Posts: 236
Eth727
Loc: San Diego
Reg: 04-17-19
11-12-19 11:22 PM - Post#2780087    
    In response to ragtp66

Yeah I ran a cable straight from BATT to the blower and it worked. I followed the brown wire to bulkhead connector, opened it and found dirt. Cleaned it out and got the fan working again thanks.



 


Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

243 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.087 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 10:35 AM
Top