Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomJoin the Community today
Ecklers AutoMotiveNu-Relics Power Windows





Username Post: 94 Vortec Issue        (Topic#357685)
Gladiator 
Poster
Posts: 45
Gladiator
Age: 29
Loc: Ohio
Reg: 12-31-16
08-16-19 07:45 PM - Post#2773350    

I'm working on a 94 Astro with the W code 4.3 Vortec, for a family friend. It had sat for several years and wouldn't start, I replaced the fuel pump/filter, sending unit and cleaned the tank, and it started up but ran rough.

I changed the plugs on it and it ran a little better, but occasionally it would act up and not want to start easily, act like it wanted to die and even with it floored it wouldn't rev, other times it idles pretty smoothly and has decent pickup.

I put on a new cap/rotor,pcv,vacuum lines,cleaned egr and put on a screened gasket, pulled and cleaned the plenum, checked for fuel leakage inside and didn't see any of the typical leaks, a latter fuel pressure test also confirmed it was holding pressure. I did find the new return line was kinked and pressure was at 80psi, I fixed the line and the pressure dropped to the 50s.

Today they took it out for a drive and was doing fine but after about 6 miles it started cutting out on them and wouldn't respond to throttle, then they got it to run good enough to get back.

Anyone have any ideas? I was wondering if it sounds at all like a coil issue, as my G20 full size was said to have had kind of a similar problem by the previous owner when the coil went bad.

1995 Chevy G20 350 TBI Gladiator conversion
2004 Mustang GT 4.6L V8


 




Gladiator 
Poster
Posts: 45
Gladiator
Age: 29
Loc: Ohio
Reg: 12-31-16
08-17-19 02:56 PM - Post#2773406    
    In response to Gladiator

Today I replaced the coolant temp sensor, the ignition coil and put on new plug wires, it starts up instantly each time and idles ok, but it still wont rev past 1/4 throttle and backfires when you do, anyone have any idea's I don't want to throw anymore parts at it until I have some idea of what the issue is.

I ordered a 12 pin usb obd1 adapter I can use with aldldroid so I can check some of the other pids.

1995 Chevy G20 350 TBI Gladiator conversion
2004 Mustang GT 4.6L V8


 
gchemist 
Senior Chevytalk Moderator
Posts: 24929
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
08-17-19 03:41 PM - Post#2773409    
    In response to Gladiator

Have you checked compression? Did you take the upper intake off? Did does smell like rich fuel? Was the even side lower intake dirty? Did have traces of fuel runs? The single injector is notorious for leaking. I replace mine last year. Made a huge differences. I’ll search for my post.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
Gladiator 
Poster
Posts: 45
Gladiator
Age: 29
Loc: Ohio
Reg: 12-31-16
08-17-19 03:47 PM - Post#2773410    
    In response to gchemist

I took it off but it wasn't wet inside from gas, just remnant oil residue from the pcv. Didn't see any gas spray from nylon fuel lines and nothing leaked from the regulator, pressure was holding good. I hadn't done a compression check. I will probably just have to wait till obd 1 adapter gets here to check the readings.

1995 Chevy G20 350 TBI Gladiator conversion
2004 Mustang GT 4.6L V8


 
gchemist 
Senior Chevytalk Moderator
Posts: 24929
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
08-17-19 03:49 PM - Post#2773411    
    In response to Gladiator

Good reading: https://www.chevytalk.org/fusionbb/showtopic.php?t...

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
Gladiator 
Poster
Posts: 45
Gladiator
Age: 29
Loc: Ohio
Reg: 12-31-16
08-17-19 03:51 PM - Post#2773412    
    In response to gchemist

I will give it a read, thank you.

1995 Chevy G20 350 TBI Gladiator conversion
2004 Mustang GT 4.6L V8


 
gchemist 
Senior Chevytalk Moderator
Posts: 24929
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
08-17-19 03:58 PM - Post#2773413    
    In response to Gladiator

Is the cat clogged? Firing order verified? Has the ignition module been tested?

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
gchemist 
Senior Chevytalk Moderator
Posts: 24929
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
08-17-19 04:01 PM - Post#2773414    
    In response to gchemist

Big check! Ohm out the pickup coil. It’s another part that acts up when hot. For a bad one, I replace the distributor.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
Gladiator 
Poster
Posts: 45
Gladiator
Age: 29
Loc: Ohio
Reg: 12-31-16
08-17-19 04:03 PM - Post#2773415    
    In response to gchemist

Firing order is good. Right now it's consistently having problems revving but before yesterday it was only randomly having issues running. I will do some more checking.

1995 Chevy G20 350 TBI Gladiator conversion
2004 Mustang GT 4.6L V8


 
gchemist 
Senior Chevytalk Moderator
Posts: 24929
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
08-18-19 05:40 AM - Post#2773451    
    In response to Gladiator

In case you need more ideas. Send me a message or email me. I'll send you a PDF file. It's a TBI troubleshooting guide. The FI systems are similar. Sequence of troubleshooting are too.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
gchemist 
Senior Chevytalk Moderator
Posts: 24929
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
08-18-19 04:40 PM - Post#2773508    
    In response to gchemist

A good source of troubleshooting info: https://troubleshootmyveh icle.com/

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
Gladiator 
Poster
Posts: 45
Gladiator
Age: 29
Loc: Ohio
Reg: 12-31-16
08-28-19 01:28 PM - Post#2774314    
    In response to gchemist

I did some datalogging with my new OBD 1 USB adapter and found all the sensors seem to be in good shape: tps, o2 sensor, map,iat,cts seem to be working fine.

It wouldn't heat up more than about 150-160 degrees so I put in a new 195f thermostat and it heats up normally now.

I got another fuel pressure loan tool and found at idle it stays around 52psi,it idles ok for the most part. When it starts to act up when you rev it, the pressure jumps to 59psi.

In park it will rev up to 3000 rpm when you push the pedal about 1/4 the way down but if you push it down any more the engine actually slows down and that's when the fuel psi goes to 59 and there's occasional intake side backfires.

O2 reading shows its switching lean/rich just fine at idle, but when you try to rev it, it does spike lean.

At idle the dataloggeer is showing the spark advance is erratic and all over the place but when you try to rev it, it stays consistent.




1995 Chevy G20 350 TBI Gladiator conversion
2004 Mustang GT 4.6L V8


 
gchemist 
Senior Chevytalk Moderator
Posts: 24929
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
08-28-19 02:18 PM - Post#2774316    
    In response to Gladiator

Have you ohm-ed the pick up coil? Erratic timing can be caused by a bad pickup coil. Corrosion will cause problems too. The pick coil casing breaks apart after years of use.

The pressure regulator may be a little weak. Pressure should be steady.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
Gladiator 
Poster
Posts: 45
Gladiator
Age: 29
Loc: Ohio
Reg: 12-31-16
08-28-19 04:15 PM - Post#2774327    
    In response to gchemist

Haven't checked the pickup yet. It revs fine up to about 3000 rpm when you hold the pedal around 1/4 throttle in park but when you push it past half throttle the engine speed actually drops down.

1995 Chevy G20 350 TBI Gladiator conversion
2004 Mustang GT 4.6L V8


 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

197 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.169 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 06:19 PM
Top