Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomJoin the Community today
Ecklers AutoMotiveNu-Relics Power Windows

Ecklers AutoMotive
Username Post: Help.......A/C goofy        (Topic#356939)
Whitetail Hunter 
"2nd Year" Platinum Supporting Member
Posts: 200
Whitetail Hunter
Age: 51
Loc: Green Bay Wisconsin
Reg: 03-28-15
06-23-19 01:20 PM - Post#2769072    

Just got my factory A/C working. It works but not right. 1st with A/C on the compressor only runs when fan speed is on medium. Not on high or low speed. 2nd. Even with A/C off and in heat the compressor runs. I have new wiring harness in dash and engine. I just dont understand.



 
Ecklers AutoMotive
Crusty66 
"7th Year" Gold Supporting Member
Posts: 356
Crusty66
Age: 59
Loc: Albany, eNZed
Reg: 11-04-12
06-24-19 12:04 PM - Post#2769161    
    In response to Whitetail Hunter

The compressor runs full time with Comfortron A/C, I think it does on the std factory also. The temperature is controlled by flaps mixing hot & cold air in the unit.

Check for vacuum leaks & make sure you have good vacuum. There are plenty of hoses to leak.

Steve
1966 Caprice 396 496 496mkII TH400


 
Texasray 
"3rd Year" Silver Supporting Member
Posts: 90
Texasray
Loc: Texas
Reg: 11-01-16
06-25-19 06:27 PM - Post#2769252    
    In response to Crusty66

Let's see. Now I have gone with a vintage Air unit but I have several of these controls in the shop but never had a working original A/C on my '66.

So if I remember correctly there is a switch on the A/C slide to active the compressor. It is on the back of the middle lever labeled "OUTLET".
While I am typing I am sitting here with the manual in my lap...:)

I finally found the Four Season system wiring on page 1A-77.

So a 14 B/Y wire leaves the fan control switch it splits one branch to the resistor the other to the "compressor switch" I noted earlier. With the fan on in any position this wire should be hot. When you more the lever to the A/C side it closes this switch and sends current to the clutch.

Your problem is probably the fan switch not energizing the control switch or the control switch itself not passing the current on. I would look at the control switch first with meter or test light make sure you have voltage on both the B/Y going in and the 14DG coming out, that's what goes to your compressor. If this switch is the problem it may also be your "Compressor run all the time" problem.

Now if you DO have "Comfortron" all this is incorrect and we will have to start over on page 1A-36.

I hope this helps.

Sam



 
Whitetail Hunter 
"2nd Year" Platinum Supporting Member
Posts: 200
Whitetail Hunter
Age: 51
Loc: Green Bay Wisconsin
Reg: 03-28-15
06-27-19 05:13 PM - Post#2769388    
    In response to Texasray

Replaced the compressor relay under the hood. Still not working right. Put a ohm meter on the (green whit stripe) wire on compressor plug. Other lead to the same wire on switch under dash. Nothing... checked again at the bulkhead connector and I get continuity. But on engine side the wire is to the bottom right. On the dash side its on the bottom left. Looks like the wires are swapped.



 
Whitetail Hunter 
"2nd Year" Platinum Supporting Member
Posts: 200
Whitetail Hunter
Age: 51
Loc: Green Bay Wisconsin
Reg: 03-28-15
06-27-19 06:14 PM - Post#2769391    
    In response to Whitetail Hunter

Switched the bottom 2 wires. Now the compressor eorks right. Now I see my fan speeds are screwy. Maybe someone can clarify. Fan switch all the way up is off. 1 click down is I think medium. 2 clicks down is high for sure. All the way down in low. That cant be right but is off all the way up or down?



 
6T5 
"2nd Year Gold Supporting Member
Posts: 215
6T5
Age: 67
Loc: Asheville, NC
Reg: 07-22-17
06-28-19 04:22 AM - Post#2769410    
    In response to Whitetail Hunter

All the way up is off, 1dn low, 2dn med 3 or all the way down is high...

...Ed

1965 Impala SS


 
Ecklers AutoMotive
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

385 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.131 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 03:15 PM
Top