Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

Ecklers AutoMotive
Username Post: 1968 Caprice-A/C Will Only Blow Thru Floor        (Topic#355759)
SSuper Dave 
Member
Posts: 413

Loc: Pearland TX
Reg: 10-02-05
03-25-19 08:52 AM - Post#2762835    

I got my '68 Caprice uncovered and ready for summer this past weekend, and found that now the a/c will only blow thru the floor vents. It's ice cold, and all functions seem to work, but the air won't blow thru the dash like it did before. Ideas? It is the standard 4 Seasons a/c, not Comfortron.
Thanks.

1968 Caprice coupe, 327/275, TH400, Ash Gold/Ivy Gold, Tach Dash, Tilt, Buckets, Console, AM/FM, Rear Defog, Disc and Rallys.
1970 El Camino, 350, TH400, 12 bolt posi, a blank slate!


 
Ecklers AutoMotive
Custom670 
Poster
Posts: 27
Custom670
Reg: 09-01-12
03-26-19 02:39 PM - Post#2762956    
    In response to SSuper Dave

I have the Four Season in my 70 Impala, so I think it could be similar.

There is one central duct behind the dash that the air enters after it is heated/cooled. The heated air dumps out the floor vent and the cooled air is blown through the dash and lap vents.

If you aren't getting cold air from the dash vents did you make sure they are opened? Silly question, but start with the basics. Next, could the hoses from the duct to the vent be damaged or broken (especially if they are original)? Perhaps some form of furry life made a home inside the duct and is clogging the air from getting out?

In 1970 cold air did not come out the floor vent, only heated air (unless the vent option was chosen). If I had cold air coming out the floor vent only, then I would think my outlets door is not functioning properly. It is vacuum operated. The vacuum pot is behind the ac/heat box inside the passenger compartment. Its also known as the a/c diverter door. Perhaps it is something simple like the vacuum hose came loose from the pot.

Good luck.



 
SSuper Dave 
Member
Posts: 413

Loc: Pearland TX
Reg: 10-02-05
03-26-19 07:20 PM - Post#2762962    
    In response to Custom670

Found the problem this evening. In order to get the car started, I had to replace a coil that mysteriously failed over the winter. When doing so, I knocked the vacuum line lose that goes from the manifold to the "bean can" reservoir, and had no vacuum to the system. I hooked it back up and all is working normally now.


1968 Caprice coupe, 327/275, TH400, Ash Gold/Ivy Gold, Tach Dash, Tilt, Buckets, Console, AM/FM, Rear Defog, Disc and Rallys.
1970 El Camino, 350, TH400, 12 bolt posi, a blank slate!


 
Ecklers AutoMotive
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

160 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.116 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 09:39 PM
Top