Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

Ecklers AutoMotive
Username Post: Open circuit madness        (Topic#355602)
SS 68 Steve 
Poster
Posts: 3

Loc: AZ
Reg: 09-27-14
03-13-19 02:31 PM - Post#2762006    

Hi All,

Newer battery dies overnight. Charge it for a short bit & it starts right up & continues to start up all day. No clock & dummy gauges. Glove box, courtesy lights & trunk light all turn off & remain off. Alternator appears to be functioning properly. Recently rebuilt 327, 400 trans. Any ideas?



 
Ecklers AutoMotive
japete92 
"5th Year" Silver Supporting Member
Posts: 1156
japete92
Loc: No. Virginia
Reg: 01-18-13
03-13-19 04:52 PM - Post#2762017    
    In response to SS 68 Steve

This may be helpful:

https://www.americanautowire.com/view-faq/dead-bat...


Pete



 
SS 68 Steve 
Poster
Posts: 3

Loc: AZ
Reg: 09-27-14
03-13-19 10:13 PM - Post#2762037    
    In response to japete92

Thanks for the helpful link. It appears that the voltage regulator is the culprit. Will replace & see what happens.



 
SS 68 Steve 
Poster
Posts: 3

Loc: AZ
Reg: 09-27-14
03-14-19 09:22 PM - Post#2762105    
    In response to SS 68 Steve

After further testing it turns out it's actually a bad diode in the alternator.



 
Ecklers AutoMotive
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

82 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.103 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 10:14 PM
Top