Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: Edelbrock 1406 stuck throttle        (Topic#355555)
57 Al 
Poster
Posts: 4

Age: 68
Loc: Minden, LA
Reg: 02-02-14
03-10-19 07:17 AM - Post#2761715    

After parking my car for about a week, I tried to start it and the throttle linkage is stuck like it's in a bind.



 


acardon 
Ultra Senior Member
Posts: 11298
acardon
Loc: DFW TEXAS
Reg: 03-25-05
03-10-19 08:23 AM - Post#2761725    
    In response to 57 Al

Welcome!
The rear motor mounts may have broken, causing the rear of the engine to drop down and put the linkage in a bind. Link to linkage.

Don
66 Corvair (driving)
57 2dr HT (driving)
56 2dr HT (waiting to be restored)


 
57 Al 
Poster
Posts: 4

Age: 68
Loc: Minden, LA
Reg: 02-02-14
03-10-19 02:38 PM - Post#2761759    
    In response to acardon

Motor mounts o.k. Everything worked fine last time I drove it. I've started it up a few times since then . But yesterday I tried to start it and throttle was stuck. Un hooked it from petal, still stuck. Unkooked acceldrator pump, still stuck. Any ideas?



 
steve65 
"4th Year" Gold Supporting Member
Posts: 765
steve65
Age: 61
Loc: new westminster bc
Reg: 09-25-13
03-11-19 09:35 AM - Post#2761833    
    In response to 57 Al

Have you tried shooting penetrating oil on/in the butterfly valve shaft(s)? With all the linkage disconnected, it seems like the only other place to seize.
Steve

Steve Duncan
65 Impala SS Convertible
Ermine White/ Black Top
357 4 spd auto



 
57 Al 
Poster
Posts: 4

Age: 68
Loc: Minden, LA
Reg: 02-02-14
03-13-19 02:07 PM - Post#2762011    
    In response to steve65

Thanks, I'm gonna take it off and try to figure it out. I put a spacer under it awhile back. Coulx be binding on it. Will report back.



 
57 Al 
Poster
Posts: 4

Age: 68
Loc: Minden, LA
Reg: 02-02-14
03-24-19 06:38 PM - Post#2762800    
    In response to 57 Al

T V cable was stuck. Greased it up good. Everything fine now.



 


Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

354 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.094 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 07:50 PM
Top