Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Join the Community todayDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy





Username Post: 95 K1500 w\305 TBI EGR problem        (Topic#354511)
VChief101 
Poster
Posts: 8

Reg: 12-22-18
12-22-18 03:35 PM - Post#2755308    

Bad EGR valve recently replaced. Truck now bucks and backfires after it warms up. In diagnostic mode the EGR valve opens when vacuum is placed on line from TBI to egr solenoid. EGR does not open when vacuum placed on same line after engine warm. So I replaced coolant temperature sensor with Duralast sensor, still won't open and runs worse! Any ideas?




 




rockfangd 
"6th Year" Gold Supporting Member
Posts: 2707
rockfangd
Age: 33
Loc: Utica ny
Reg: 04-13-10
12-24-18 10:36 PM - Post#2755528    
    In response to VChief101

Welcome to ChevyTalk.
I dont care for Duralast first off. MAy be just me.
Like to stick with oem or standard if oe is not available.
Is the vacuum getting supplied to the solenoid, and from the solenoid to the valve?
Is it the correct valve? There is 2 types, positive, and negative. Must match.
The fact you are saying it is running worse makes me wonder if it has the wrong valve installed.

Old School GM fan FOREVER


Edited by rockfangd on 12-24-18 10:39 PM. Reason for edit: No reason given.

 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

183 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.056 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 01:39 AM
Top