Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: Wipers only wipe on low        (Topic#353810)
ggenovez 
Senior Member
Posts: 960

Loc: DFW, Tx
Reg: 06-08-05
11-08-18 09:20 AM - Post#2750767    

Hi all,

I have a problem that's gotten progressively worse.

As it stands my wipers that have delay, low and hi only work on the low speed, now matter what setting I set the stalk to.

Also turning the wipers off requires I set it to mist and hold on the stalk until the wipers are at the lowest setting. As soon as I release, they stop.

I've replaced the stalk. Same problem.

Any thoughts?

Thanks

1990 r-1500 suburban, 350 TBI, 2wd


 
gchemist 
Senior Chevytalk Moderator
Posts: 24496
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
11-12-18 06:04 AM - Post#2751133    
    In response to ggenovez

The wiper motor has constant power. It's why sometimes they wipe when you turn the key. Check the ground strap at the motor. Connections too. You might need to replace the wiper motor. You can use a voltmeter to test power feed into the motor.

'83 Silverardo XST - ZZ4 powered
'95 Jimmy SLT (Bought @131,814)
'96 GMC Jimmy LS Ret. @236651 miles


 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

76 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.128 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 07:23 PM
Top