Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: mini HEI troubleshooting        (Topic#353721)
Alegm 
Poster
Posts: 25
Alegm
Reg: 01-05-13
11-01-18 08:29 PM - Post#2750225    

Hi folks:
in mars this year I bought a Mini HEI kit (incluiding distributor, spark plugs, spark wires set and both square and round coils) from Langdons

I installed the kit following all the instructions(changed the power wire to #10, spark plugs gap close to .060. timing etc) and I used the round coil to start 'cause at this point i had not place where to set the square one. Well the car ran like never before for 1 month or something, i was very happy though, but one day after turn it off and fire it up againg and driving for 2 miles or something the car started to hesitate, jerking and the valves were pinging as if the timimg was wrong..... at some point when I stoped pushing the gas pedal the engine just died and there were not way to fire it up again.(at this point I used my old Delco-Remy points distributor to comeback home).
Next day I tried to restart de egine with the mini HEI again but it didnt worked either... I blamed the round coil and used the old distributor ever since.(at this point i was so disapointed that didnt bother to call Tom and did nothing)
Yesterday i felt enthusiastic again and fabricated a support for the square coil, put in the HEI again, fire it up and ran like crazy for 2 miles or something after wich the same problem came back again. i took the dis. cap out and touched the 4 pins module, it was cold, no apparent problems
Now I know it cant be the coil 'cause i've used both,

what do you guys think may be causing this problems??

Thanks in advance

Alex



 

Ecklers AutoMotive

Rick_L 
Honored Member
Posts: 27511
Rick_L
Loc: Katy, Tx, USA
Reg: 07-06-00
11-02-18 06:37 AM - Post#2750247    
    In response to Alegm

Not much left but the module.



 
IgnitionMan 
Valued Contributor
Posts: 3511

Reg: 04-15-05
11-02-18 10:56 AM - Post#2750267    
    In response to Alegm

Posted info to to your PM, a lot more than just one component.



 

Ecklers AutoMotive

Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

173 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.074 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 09:07 AM
Top