Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: Steering locks up.        (Topic#353391)
kwase 
Poster
Posts: 46

Reg: 05-05-12
10-10-18 11:30 AM - Post#2748339    

I have a 61 Impala with a 605 steering box. I recently installed new hoses and had the box rebuilt. I also installed a CPP centerlink kit to replace the original one that has that little metal ball going to the pitman arm. Now when I steer it will lock up after a few turns of the steering wheel. If I cut the car off and jack it up a little to relieve pressure on the tires it turns just fine. But when I cut the car on and lower it and steer it a couple times it will just lock up. Has anyone ever encountered this?



 




Jalapeno 
Senior Member
Posts: 9731
Jalapeno
Loc: The Republic of Texas
Reg: 04-30-00
10-10-18 07:41 PM - Post#2748381    
    In response to kwase

Was the 605 working correctly before the rebuild? I suspect there is now something wrong with the mechanical part of the gear because of poor assembly.



Jalapeno


 
Andy4639 
Frequent Contributor
Posts: 1168

Age: 58
Loc: Liberty, SC
Reg: 08-06-16
10-11-18 03:38 AM - Post#2748402    
    In response to kwase

Are you sure the center link is in correctly? The idler arm on the passenger side has to be correct to are it will bind up.

Ask me how I know.




1956 Bel Air - LT-1/4l60
1964 SS Impala -350 crate/powerglide
1967 Ramp truck - 350/ 4 speed
1971 C 10 - 6.0 LS / 4l80e 4:10 gears 30 years owner
94 Elderado
2000 S-10
2008 LTZ Tahoe
2011 Treverse


 
kwase 
Poster
Posts: 46

Reg: 05-05-12
10-12-18 02:00 PM - Post#2748522    
    In response to Jalapeno

The steering box was just fine before the rebuild. I took it back to them and they said they tested it and it was fine.



 
kwase 
Poster
Posts: 46

Reg: 05-05-12
10-12-18 02:02 PM - Post#2748523    
    In response to Andy4639

I will double check the center link tomorrow. the steering works just fine when the car is off and it's lifted a little off the ground. I just got a new pump that I'm going to install tomorrow and we'll see how that goes.



 
56_Kruiser 
Valued Contributor
Posts: 2775
56_Kruiser
Loc: St. Augustine, Fl
Reg: 09-23-05
10-12-18 02:51 PM - Post#2748525    
    In response to kwase

The angles of that linkage changes with weight on the wheels. That is why the nuts on a couple of them aren't torqued while in the air, but with the wheels on the ground.


1956 Chevy
Vid of 61
61 Chevy


 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

240 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.097 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 01:11 AM
Top