Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: 2013 Chevy Cruze        (Topic#353285)
Jwood 
Poster
Posts: 1

Reg: 10-03-18
10-03-18 02:51 PM - Post#2747802    

I have a 2013 Chevy Cruze. It has 52,000 miles on it. I was driving to the store and the stabilitrak warning light came on and, the cars power decreased. It restarted and drove slowly for a few seconds till it died and, wouldn't restart. When trying to restart it, the engine turned and when letting loose of the key instead of stopping the engines turned for an extended period of time then it would stop. After letting it sit a few days there is no power like the battery is dead. The mechanic we took it to didn't run the diagnostic test like we wanted. He said he did a charge test and, there was no charge to the valves leading him to think it's the timing. There was no funny noises to the motor. Anyone have thoughts on what's going on with it? Thank you for your time!



 




JasonZ 
Ultra Senior Member
Posts: 11609

Age: 32
Loc: San Antonio Texas
Reg: 02-21-03
10-29-19 10:14 PM - Post#2779110    
    In response to Jwood

I’ve just replaced the battery when that issue comes up. Also clean the grounds up really well and reinstall. I know it’s a old post. But this will help someone in need later on.

Don't go BROKE trying to look RICH. Act your WAGE!!


 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

888 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.203 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 09:20 PM
Top