Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: 2013 Chevy Cruze        (Topic#353285)
Jwood 
Poster
Posts: 1

Reg: 10-03-18
10-03-18 01:51 PM - Post#2747802    

I have a 2013 Chevy Cruze. It has 52,000 miles on it. I was driving to the store and the stabilitrak warning light came on and, the cars power decreased. It restarted and drove slowly for a few seconds till it died and, wouldn't restart. When trying to restart it, the engine turned and when letting loose of the key instead of stopping the engines turned for an extended period of time then it would stop. After letting it sit a few days there is no power like the battery is dead. The mechanic we took it to didn't run the diagnostic test like we wanted. He said he did a charge test and, there was no charge to the valves leading him to think it's the timing. There was no funny noises to the motor. Anyone have thoughts on what's going on with it? Thank you for your time!



 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

158 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.09 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 02:31 PM
Top