Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: Check Engine light Question Please?        (Topic#352091)
Willow 
Contributor
Posts: 138

Reg: 05-25-12
07-18-18 05:55 PM - Post#2740450    

Greetings All:
Question Please: 2012 Silverado 1500 crew cab, 5.3.
Been getting very intermittent check Engine light.
Had auto store run scan, told me speed sensor.
Here’s my problem. Have to make a trip for sick family, probably 450 miles or so round trip. Truck running fine.
Is it safe to make this trip? No light on now as auto store reset. Would appreciate your help as I’m kinda between a rock and hard place. Need to go but don’t need problems.
Thanks in advance
Willow




Edited by Willow on 07-18-18 05:56 PM. Reason for edit: No reason given.

 
Shepherd 
Frequent Contributor
Posts: 1365

Loc: Lake George, NY
Reg: 11-11-15
07-18-18 06:36 PM - Post#2740459    
    In response to Willow

What was the code? Look at this. https://www.yourmechanic.com/article/symptoms-of-a ...



Edited by Shepherd on 07-18-18 06:40 PM. Reason for edit: No reason given.

 
Willow 
Contributor
Posts: 138

Reg: 05-25-12
07-18-18 11:16 PM - Post#2740492    
    In response to Willow

Anyone???



 
Willow 
Contributor
Posts: 138

Reg: 05-25-12
07-18-18 11:35 PM - Post#2740494    
    In response to Shepherd

Don’t know the code. He just said speed sensor and cleared check engine light. Just hoping safe to make trip. Shifting fine, cruise works great, speedo fine. All seems well.



 
Shepherd 
Frequent Contributor
Posts: 1365

Loc: Lake George, NY
Reg: 11-11-15
07-19-18 06:05 PM - Post#2740569    
    In response to Willow

Thst link I sent you has all effects of a speed sensor problem.



 
Willow 
Contributor
Posts: 138

Reg: 05-25-12
07-22-18 05:44 PM - Post#2740829    
    In response to Shepherd

Update:!!!! Drove almost 450 miles with check engine light on .
Everything worked & truck ran great. About 30 miles from my house, Check Engine light goes off? Truck still running
Fine. Everything seems normal?
Regards: Willow 👍😊



 
Willow 
Contributor
Posts: 138

Reg: 05-25-12
07-23-18 02:12 PM - Post#2740920    
    In response to Willow

Update!!!
Damn check engine light just went back on while starting truck and now staying on again. Will have codes run on Wednesday
And write it down to share here. Getting very frustrating!!




 
YOUNG57 
Frequent Contributor
Posts: 1051

Loc: Tennessee
Reg: 12-06-10
08-10-18 07:46 AM - Post#2742582    
    In response to Willow

My son’s ‘03 Tahoe kept getting intermittent Check Engine light. Some odd functions would not work or come on by themselves like rear wiper, 4WD shifting into 4WD LOW. Turned out to be a failing/dying battery. Started fine every time but apparently it had low voltage. Replaced the battery and all issues went away, go figure ?????



 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

296 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.102 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 10:55 PM
Top