Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: Odd shifting no power        (Topic#351896)
Donolie 
"7th Year" Gold Supporting Member
Posts: 267
Donolie
Loc: Detroit
Reg: 03-17-08
07-06-18 09:27 AM - Post#2739180    

95' c1500 350

My girlfriends truck is not shifting correctly and won't rev above 2,000 rpm except in park it will rev fine. Even in neutral it won't go above 2,000 rpm. The trans doesn't want to shift without letting off the throttle, unless you don't go above 1/10th throttle.


Any ideas?



Thanks, Don



 
bowtie44s 
Valued Contributor
Posts: 4032
bowtie44s
Age: 35
Loc: wv
Reg: 08-29-12
07-06-18 10:40 AM - Post#2739187    
    In response to Donolie

Have you checked fuel pressure?

Jeff

'88 Chevy K3500, aluminum head roller cam 511in³ stroker 10.5:1 compression, 96 NV 4500, 94-98 grille, 305/70-16 (33x12) BF Goodrich KM2s, 91 cluster swap


 
Junkyardwarrior 
Contributor
Posts: 331

Loc: Yuma AZ
Reg: 02-25-15
07-06-18 10:41 AM - Post#2739188    
    In response to Donolie

Sounds like the transmission has crapped out to be honest. I had a th350 do that to me once with the exception of the rev issue. Refused to shift on the go stick, however that motor and trans had no electronic controls, which could be the rev issue. Any codes?

"8 cylinders of why the f&@% not" - me


 
Donolie 
"7th Year" Gold Supporting Member
Posts: 267
Donolie
Loc: Detroit
Reg: 03-17-08
07-06-18 12:02 PM - Post#2739194    
    In response to bowtie44s

I've not checked the fuel pressure. It starts and idels fine.



 
Donolie 
"7th Year" Gold Supporting Member
Posts: 267
Donolie
Loc: Detroit
Reg: 03-17-08
07-06-18 12:04 PM - Post#2739195    
    In response to Junkyardwarrior

There are no codes. It almost feels like the TPS has a bad spot causing it to bog past a certain point, but while in park it feels fine.



 
bowtie44s 
Valued Contributor
Posts: 4032
bowtie44s
Age: 35
Loc: wv
Reg: 08-29-12
07-06-18 12:08 PM - Post#2739196    
    In response to Donolie

  • Donolie Said:
I've not checked the fuel pressure. It starts and idels fine.



If you have 5psi fuel pressure it will probably start and idle fine. It won't show any symptoms and you put a little load on it. Not saying that is your problem, but it's easy to rule it out.

Jeff

'88 Chevy K3500, aluminum head roller cam 511in³ stroker 10.5:1 compression, 96 NV 4500, 94-98 grille, 305/70-16 (33x12) BF Goodrich KM2s, 91 cluster swap


 
Shepherd 
Frequent Contributor
Posts: 1418

Loc: Lake George, NY
Reg: 11-11-15
07-06-18 12:09 PM - Post#2739197    
    In response to Donolie

Clogged cat is another strong possibility.



 
Junkyardwarrior 
Contributor
Posts: 331

Loc: Yuma AZ
Reg: 02-25-15
07-06-18 01:01 PM - Post#2739203    
    In response to Shepherd

True. Fuel pressure is a big one. Also in a 95 the only thing it would have a TPS for is the transmission controls. Shouldn't affect the motor revving. To check the catalytic converters, just pull the front 2 O2 sensors out and see if it still misbehaves with the pipes open. It'll be loud but it should give you some clue there.

"8 cylinders of why the f&@% not" - me


 
Donolie 
"7th Year" Gold Supporting Member
Posts: 267
Donolie
Loc: Detroit
Reg: 03-17-08
07-06-18 01:33 PM - Post#2739207    
    In response to Junkyardwarrior

I've had test pipe in place of the cat since about 80,000 miles, we are now at about 210,000



 
Junkyardwarrior 
Contributor
Posts: 331

Loc: Yuma AZ
Reg: 02-25-15
07-06-18 08:57 PM - Post#2739244    
    In response to Donolie

210k on what I'm assuming should be a 4L60. I'm willing to bet the trans is shot. Ever change the tranny fluid?

"8 cylinders of why the f&@% not" - me


 
Donolie 
"7th Year" Gold Supporting Member
Posts: 267
Donolie
Loc: Detroit
Reg: 03-17-08
07-07-18 12:57 PM - Post#2739283    
    In response to Junkyardwarrior

I've never changed it. What's odd is last night and today she said it's driving fine. Would low fuel pressure be intermittent? The pump and sending unit we're replaced last summer because of rust.



 
CowboyTrukr 
"7th Year" Silver Supporting Member
Posts: 4014
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
07-07-18 01:21 PM - Post#2739287    
    In response to Donolie

Yes, the pressure could be fluctuating.

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD
‘87 GMC S15 SCLB 4.3 Auto - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

472 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.136 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 07:27 AM
Top