Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: 67 impala gauge cluster harness question        (Topic#351004)
Jordie 
Contributor
Posts: 101

Loc: Australia
Reg: 10-02-13
05-07-18 01:02 AM - Post#2733259    

Hi all,

I just bought a gauge cluster with tach for my Australian built 67 impala. (For those who don’t know I’m getting the American dash converted to suit a RHD impala. The Australian built 67 imaplas had the 65-66 American dash). I’m just wondering will I need the correct harness for the cluster or can I use my current harness (from the 65-66 American style dash, yes all the bulbs still work correctly etc) and just connect the sending wires (fuel, ampage, oil and temp) to the prongs on the back of the cluster? Would this still work as long as it’s earthed? Or does anyone know where to find a harness for the cluster?

Cheers



 
This Forum is Sponsored by
1-800-IMPALAS  *  www.impalas.com
Visit Impala Bob's forum on ChevyTalk
BigDogSS 
"9th Year" Silver Supporting Member
Posts: 4605
BigDogSS
Loc: SoCal
Reg: 12-21-01
05-10-18 09:00 AM - Post#2733594    
    In response to Jordie

No you can't use your original harness. Ammerican Auto Wire is a Chevy Talk sponsor. They carry the correct harness.



    1967 Chevrolet Impala SS convertible - Ermine White C1
    1967 Chevrolet Impala SS 396 - Marina Blue FF



Edited by BigDogSS on 05-10-18 09:01 AM. Reason for edit: No reason given.

 
Jordie 
Contributor
Posts: 101

Loc: Australia
Reg: 10-02-13
05-11-18 05:31 PM - Post#2733732    
    In response to BigDogSS

Thanks for that! I’ll still have to run each gauge (oil fuel and temp) to its correct sender, ampage to alternator and tach to coil though won’t i?



 
aawtech 
American Autowire "Site Sponsor"
Posts: 5067

Loc: Bellmawr, NJ
Reg: 09-11-06
05-12-18 08:25 AM - Post#2733766    
    In response to Jordie

  • Jordie Said:
Hi all,

I just bought a gauge cluster with tach for my Australian built 67 impala. (For those who don’t know I’m getting the American dash converted to suit a RHD impala. The Australian built 67 imaplas had the 65-66 American dash). I’m just wondering will I need the correct harness for the cluster or can I use my current harness (from the 65-66 American style dash, yes all the bulbs still work correctly etc) and just connect the sending wires (fuel, ampage, oil and temp) to the prongs on the back of the cluster? Would this still work as long as it’s earthed? Or does anyone know where to find a harness for the cluster?

Cheers



Wow, quite a project. We cannot help with a RH drive harness first of all. Next, the 65 dash is hard wired and did not use a printed circuit like the 67 does. They are not even remotely close to being able to work. In addition, if it is a true gauge cluster with live gauges and tach, the ammeter will never work properly if at all. The ammeter circuit was based on a given length of wire in the shunt circuits (105 and 106), and when you change the length of those wires, the gauge does not work properly, and will usually melt the traces on the PC board. You are going to have to create you own harness using the connections form the 67 PC board and the 65 dash, and do not wire or use the ammeter. No easy answer. In addition, the 65 and 67 cars are not pinned out the same at the firewall. Wish I could be more positive and offer a better solution, but I can't.

Donny




 
Jordie 
Contributor
Posts: 101

Loc: Australia
Reg: 10-02-13
05-12-18 05:37 PM - Post#2733814    
    In response to aawtech

Thanks mate that does help a little

So apart from the ampage meter I’d just hook the other up as usual? Oil pressure to sender, fuel to sender, temp to sender, tach to coil and speedos obviously normal? lol



 
Jordie 
Contributor
Posts: 101

Loc: Australia
Reg: 10-02-13
05-19-18 12:08 AM - Post#2734312    
    In response to Jordie

I have successfully got the 67 original gauge cluster working properly with the 65-66 wire harness.

But using the lights on the 65-66 (or Australian built 67) harness I had to add two extra lights. I then made my own power harness and ground harness for the tach, (earthed to cluster) water temp, fuel and ampage meters. I then have each gauge running to its correct sender. They were all easy to figure out except the ampage gauge, it takes some work. But if anyone needs a diagram to create the harness I’m happy to help out



 
This Forum is Sponsored by
1-800-IMPALAS  *  www.impalas.com
Visit Impala Bob's forum on ChevyTalk
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

412 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.098 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 04:20 AM
Top