Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: Electrical issues        (Topic#350537)
old_gto 
Needs to Get Out More Member
Posts: 10920
old_gto
Loc: Orlando, FLA
Reg: 07-13-00
04-08-18 03:45 PM - Post#2730379    

Hello everybody! It`s been a very long time since I`ve been on. We`re finishing up the 65 Fleetside, and are having electrical problems.
Let me get you caught up. We swapped the 292 six for a 1966 283, with a T350 trans. All new wiring harnesses, new switches & sending units, flashers, bulbs & bulb sockets. The ONLY original electrical piece is the instrument cluster.
The engine starts, & runs smooth. But we`re having the following issues....

1. Rear tag light and both tail lights work, but when brakes are applied, left side lights up, but right side goes out. Right side also goes out when right turn signal is turned on.

2. When left turn signal is turned on, left rear lights up, but is on constant & does not flash.

3. Front parking lights work, but if either left or right turn signal is turned on, both flash at the same time.

4. Headlights do not work with pull out switch, unless dimmer switch is pushed, then low beams come on. Lights will then go off with pull out switch, but will not come back on unless dimmer is pressed again. No high beams work at all.

5. Instrument panel lights work, but dome light does not.

6. Turn indicators on dash both flash at same time if either left or right turn signal is turned on.

So, any electrical gurus that may be able to help "shed some light" on our predicament? (Pun intended)


The only thing I`m sure of, is that I`m not sure of anything.
71 Corvette, 97 burb, 66 GTO, 69 Grand Prix, 65 Mustang, 65 C-10 Fleetside, 74 Camaro
Too many toys, not enough play time!


 
bobschevytrucks.com Ecklers

jktucker92 
Silver Supporting Member
Posts: 199
jktucker92
Reg: 02-05-17
04-09-18 11:09 AM - Post#2730468    
    In response to old_gto

Did you replace the turn signal switch? It can cause a lot of these issues. It shouldn't affect the headlight issue or the dome light, but it can definitely affect the brake lights and turn signals. The turn signal switch has several metal pieces inside that switch power to the rear brake/turn signal light between the brake circuit and the turn signal circuit. I remember pulling it apart and bending and cleaning the contacts inside several times to get it to work properly.



 
old_gto 
Needs to Get Out More Member
Posts: 10920
old_gto
Loc: Orlando, FLA
Reg: 07-13-00
04-09-18 12:56 PM - Post#2730470    
    In response to jktucker92

Yes, it`s new also.... but that doesn`t mean it`s any good, considering all the junk I`ve bought from China in the last couple years! We`ll pull it apart and take a look, THANKS!

The only thing I`m sure of, is that I`m not sure of anything.
71 Corvette, 97 burb, 66 GTO, 69 Grand Prix, 65 Mustang, 65 C-10 Fleetside, 74 Camaro
Too many toys, not enough play time!


 
GreatNorthWoods 
"4th Year" Silver Supporting Member
Posts: 858
GreatNorthWoods
Age: 76
Loc: Littleton, New Hampshire,...
Reg: 03-31-02
04-10-18 05:19 AM - Post#2730541    
    In response to old_gto

  • old_gto Said:
Hello everybody! It`s been a very long time since I`ve been on. We`re finishing up the 65 Fleetside, and are having electrical problems.
Let me get you caught up. We swapped the 292 six for a 1966 283, with a T350 trans. All new wiring harnesses, new switches & sending units, flashers, bulbs & bulb sockets. The ONLY original electrical piece is the instrument cluster.
The engine starts, & runs smooth. But we`re having the following issues....

1. Rear tag light and both tail lights work, but when brakes are applied, left side lights up, but right side goes out. Right side also goes out when right turn signal is turned on.

2. When left turn signal is turned on, left rear lights up, but is on constant & does not flash.

3. Front parking lights work, but if either left or right turn signal is turned on, both flash at the same time.

4. Headlights do not work with pull out switch, unless dimmer switch is pushed, then low beams come on. Lights will then go off with pull out switch, but will not come back on unless dimmer is pressed again. No high beams work at all.

5. Instrument panel lights work, but dome light does not.

6. Turn indicators on dash both flash at same time if either left or right turn signal is turned on.

So, any electrical gurus that may be able to help "shed some light" on our predicament? (Pun intended)




No electrical guru here but I have done a lot of electrical work including wiring several cars from scratch without a kit. It's hard to diagnose electrical problems without being there but here is my opinion. I think number 1 is being caused by a bad ground. Be sure the light housings are grounded properly. Flashers will not work unless both front and rear on same side have good bulbs front and rear. Make sure both the front and rear bulbs are good. I think number 3 is bad wiring. Somehow you have both front light signals wired together rather than separately. I think number 4 is either a bad dimmer switch or another wiring snafu where the headlight switch is being fed from the dimmer switch. Power should go to the headlight switch first and then to the dimmer switch and then to the headlights. Most dome lights are hot all the time and work only when grounded. Make sure that there is power going to the dome light and that when it is turned on from the headlight switch that it becomes grounded. The turn indicator problem on the dash is related to the wiring issue on the front directional signals and should clear up when that is corrected. Those are my guesses. Wiring can be very frustrating. Good luck.


Vern

1953 Chevy Belair Sport Coupe - 355 Blueprint Engine, 700-R4, Vintage Air, EZ Wire, Ididit column, Cruise/Tilt, 59 Vette Steering Wheel, 4-Wheel Disc Brakes, Posies Springs, Coker Radials, Nova 10-bolt, Mustang II front, Continental Kit


 
GreatNorthWoods 
"4th Year" Silver Supporting Member
Posts: 858
GreatNorthWoods
Age: 76
Loc: Littleton, New Hampshire,...
Reg: 03-31-02
04-16-18 03:46 PM - Post#2731197    
    In response to old_gto

Were you able to get any of your wiring woes corrected?

Vern

1953 Chevy Belair Sport Coupe - 355 Blueprint Engine, 700-R4, Vintage Air, EZ Wire, Ididit column, Cruise/Tilt, 59 Vette Steering Wheel, 4-Wheel Disc Brakes, Posies Springs, Coker Radials, Nova 10-bolt, Mustang II front, Continental Kit


 
old_gto 
Needs to Get Out More Member
Posts: 10920
old_gto
Loc: Orlando, FLA
Reg: 07-13-00
04-18-18 12:57 PM - Post#2731428    
    In response to GreatNorthWoods

Running redundant ground jumpers from light buckets to frame.... but everything seems to be pointing to a faulty turn signal switch. We found a skinned wire, and another one was loose. That switch was new.... but so was the stop light switch that fell apart in my son`s hand, LOL! Will post an update when we get it all cleared up.

The only thing I`m sure of, is that I`m not sure of anything.
71 Corvette, 97 burb, 66 GTO, 69 Grand Prix, 65 Mustang, 65 C-10 Fleetside, 74 Camaro
Too many toys, not enough play time!


 
Todd W. White 
Contributor
Posts: 279
Todd W. White
Loc: Sapulpa, Oklahoma
Reg: 02-08-08
04-25-18 07:13 PM - Post#2732212    
    In response to old_gto

After 4 failed attempts using imported units, I finally found an American made turn signal switch that works properly. It is extremely well made, and is manufactured using the original GM tooling and is the correct part number for our trucks.

The best price I found online was from a gentleman who is a boyhood friend of the manufacturer. Tell him I sent you.

CORVETTECOLUMNS



 
bobschevytrucks.com Ecklers

Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

662 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.334 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 02:46 AM
Top