Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power WindowsRain Gear Wiper Systems
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: 94 K1500 Fan only works on cold setting        (Topic#349640)
Anonymous 

02-13-18 12:33 PM - Post#2724268    

Hey everyone. I am having some climate control issues, my heat blows hot and strong but it only works on defrost mode. Nothing will come out of the vents for face or feet. If I switch the temperature to the cold position it will blow out of the face and feet and defrost vents no problem. Temp blend door? My heater motor also only works on medium and high which I would assume is the resistor.



 
CowboyTrukr 
"7th Year" Silver Supporting Member
Posts: 3989
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
02-13-18 08:48 PM - Post#2724314    
    In response to djinc91

Start with fixing the speed control first. Yes, the resistor pack is bad. The blower fan may be going out. Higher current draw from a dying/dirty bliss burns out the resistor.

Mode actuator will be next. Check it’s operstion to make sure it hits all settings. This is the one above the accelerator pedal.

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD
‘87 GMC S15 SCLB 4.3 Auto - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

175 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.112 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 08:13 AM
Top