Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Join the Community todayDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: Kenmore oven        (Topic#349143)
Stinky 
Senior Member
Posts: 1653

Loc: Whitewater, CO
Reg: 05-25-01
01-13-18 08:10 AM - Post#2720936    

The stove stopped heating in the oven. Tis an electric Kenmore.

Any pointers?

I was thinking that I should tear it apart and check for continuity in the heating element.

The broiler still heats....which may or may not matter, 'cuz if there are relays and other gizmos involved, I am assuming that each circuit would be totally separate (or enough separate that it wouldn't matter).



Edited by Stinky on 01-13-18 08:13 AM. Reason for edit: No reason given.

 




Lorence 
Poster
Posts: 13

Reg: 05-23-17
01-13-18 01:56 PM - Post#2720952    
    In response to Stinky

Fuses? If they are still using them on stoves. Next step voltmeter and work your way back from the element to the switch(s)



 
Stinky 
Senior Member
Posts: 1653

Loc: Whitewater, CO
Reg: 05-25-01
01-20-18 06:52 PM - Post#2721635    
    In response to Lorence

I pulled both elements.

The broiler (which works), reads 15-16 ohms. The oven reads 14 ohms....when you swap them, it still doesn't work.

It has juice to the the element.

The control panel is all digital push button...that is one of my suspects.

But, I am gonna pull the back of the stove off today.



 
2blu52 
"18th Year" Silver Supporting Member
Posts: 18923
2blu52
Age: 86
Loc: Montana
Reg: 03-12-02
02-05-18 10:35 AM - Post#2723421    
    In response to Stinky

check the automatic on off feature for timed cooking. on occasion it gets bumped or reset when cleaning and that will stop the manual on off operation.

"PEACE IS THAT GLORIUS MOMENT IN HISTORY WHEN EVERY ONE STANDS AROUND RELOADING"

THOMAS JEFFERSON


 
raycow 
DECEASED
Posts: 27999
raycow
Loc: San Francisco, CA
Reg: 11-26-02
02-07-18 09:03 AM - Post#2723630    
    In response to Stinky

  • Stinky Said:
....It has juice to the the element....


Does this mean you are seeing 240V at the terminals of the element connector or socket? If yes, is the element plugged in or connected when you are taking this voltage reading?

Ray

Those who choose an automatic transmission want transportation. Those who choose a manual transmission want to drive.


 
Stinky 
Senior Member
Posts: 1653

Loc: Whitewater, CO
Reg: 05-25-01
12-08-18 07:24 PM - Post#2753922    
    In response to raycow

I changed the control panel and it is still in use, months later.




 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

2101 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.085 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 03:05 AM
Top