Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: 2003 Impala 3.4l cooling system advice.        (Topic#348555)
jgold 
Forum Newbie
Posts: 1

Reg: 12-04-17
12-04-17 05:56 PM - Post#2716898    

Hi,

I'm new to the forum. I'm trying to help out a friend who's 2003 Impala overheated one time last summer. She was driving from Phoenix to Payson. The final hill going up there is a killer. During the summer, it's probably the worst case scenario.

Anyway, it didn't vent coolant or anything, the temperature gage just went almost to the red line. She slowed down and turned on the internal heater and made the trip ok but it mad her nervous about her car.

She took the car in to a shop over the weekend and they told her she needed a new radiator, water pump, hoses and thermostat. The estimate was $1,400.

I went to a different shop to get a second opinion. They didn't do any diagnostics but told me that to replace the radiator would cost $700+. He said that they always replace the hoses and thermostat whenever they replace a radiator.

So, here's my problem. The car runs fine. It's not leaking anything, there's no coolant in the oil or air in the coolant. Running on the freeway today in 80 degree weather didn't bring the gage even to the middle. The car has 123,000 miles on it.

Do all those things need to be replaced? Do water pumps stop working? I understand replacing it if its leaking but if it's not, the impeller is moving so it should be pumping the same amount of fluid. I can also understand replacing the radiator if it's really plugged but is it? I'm kind of feeling like the car overheated more because of the extreme load rather than anything being wrong with the car.

The plan right now is for me to just replace the radiator but I have my doubts that it will fix anything. I need to do something so she feels comfortable with her car again I just don't want to fix the wrong thing.

Anyone have any advice? It would be greatly appreciated.



 




Am4wag 
Contributor
Posts: 117

Reg: 11-19-15
03-14-19 01:44 PM - Post#2762081    
    In response to jgold

Typically it's "good medicine" to replace the thermostat when replacing the radiator.If the car never overheated again,and still doesn't,why bother.But it is possible the radiator and or heater core are getting clogged preventing proper flow-especially if the coolant has never been flushed.My '01 Buick (somewhat comparible to my '04 Impala 3.4) with 3.8's radiator sprung a leak at just over 100,000 in the plastic portion(s).Bought one from Rockauto for about 70 bills and changed it out in a couple of hours.Then with this newfound pressure I discovered the 2 plastic water pump bypass tubes leaking.Changed them out and now all good.If car seems ok,I think I would atleast have the cooling system flushed-Dexcool only.Also that would indicate any crud/clogging fodder...are you loosing any coolant now?

The bearer of gossip is a small untrustworthy person who takes delight in someone else's problems. Avoid them.
Let's all make the day count. - Charlie Daniels


Edited by Am4wag on 03-14-19 01:48 PM. Reason for edit: No reason given.

 
Rucco49 
Newbie
Posts: 15

Reg: 07-25-19
08-12-19 04:40 PM - Post#2773078    
    In response to jgold

How's the car so far? My buddy's younger brother experienced the same on his 2004 Impala on a uphill drive. We'll take a look at it right after we finished installing the lights on the current truck project. There's no indication of coolant leak. We're hoping it is just a clogged rad.



Edited by Chevelle on 12-18-19 07:51 AM. Reason for edit: Affiliate link removed

 
dwi189 
Newbie
Posts: 31

Reg: 02-10-09
12-14-20 03:13 AM - Post#2809940    
    In response to jgold

Check to see if the electric cooling fans are working properly and turning on at proper temperature as well.



 
rockfangd 
"7th Year" Gold Supporting Member
Posts: 3040
rockfangd
Age: 34
Loc: Utica ny
Reg: 04-13-10
12-15-20 02:25 PM - Post#2810063    
    In response to dwi189

My best recommendation is to change the coolant. If it only happened once for a good reason then I would not waste money.
If the waterpump was bad it would be bad all the time.
Same usually with the radiator.
Thermostats can hang up and be stuck open or closed, but you say it only ran hotter than normal once.
If the car did not show a overheat message I would not worry about much.
Just make sure the coolant condition is good. That will also prevent future failure.
The coolant could have been the cause of the temp or it may have been normal. Either is possible.

Old School GM fan FOREVER


 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

966 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.145 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 03:16 PM
Top