Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows





Username Post: oil pressure or lack thereof        (Topic#339815)
gregjm25 
Forum Newbie
Posts: 13

Reg: 01-13-16
10-13-16 12:31 PM - Post#2656359    

The car is a 2011, SS, manual trans, no mods. Current showing about 83,000 miles on the odometer.

6 months ago upon starting the dash showed "no oil pressure, shut off engine". The oil pressure gauge agreed, showing 0 PSI. Got the car towed to the dealership, they said the issue was caused by a non-oem oil filter (I used a FRAM). The dealership changed the oil and filter and sent me on my way $180 later.

Since then I have changed oil twice, using an AC Delco filter both times. This past weekend, started the car (oil hadn't recently been changed) and the dash and gauge showed no oil pressure. Took the car back to the same dealership. This time they changed the oil pressure sending unit and the strainer in front of the sending unit.

My wife picked up the car from the shop after the sending unit was changed. They told her that the reason the strainer was stopped up with trash was that the engine was burning too much oil. They want the car back in for the next two oil changes to determine if the engine is using too much oil.

I feel like the dealership is "blowing smoke". Anybody had similar issues?



 




Shepherd 
Frequent Contributor
Posts: 1889

Loc: Lake George, NY
Reg: 11-11-15
10-13-16 05:46 PM - Post#2656415    
    In response to gregjm25

Seems you'd be the best judge of the car's oil consumption. There is a TSB relating to this issue, oil pump problems, look into it.



 
gregjm25 
Forum Newbie
Posts: 13

Reg: 01-13-16
10-14-16 07:18 AM - Post#2656492    
    In response to Shepherd

Never have had to add oil between oil changes, I don't think its burning any oil.



 
Shepherd 
Frequent Contributor
Posts: 1889

Loc: Lake George, NY
Reg: 11-11-15
10-14-16 03:01 PM - Post#2656543    
    In response to gregjm25

Not an oil burning issue, TSB refers to sticking pressure relief valves in the oil pump.



 
rcr3 
"15th Year" Silver Supporting Member
Posts: 3206
rcr3
Age: 68
Loc: MANHEIM PA. U.S.A.
Reg: 11-24-02
10-17-16 01:51 AM - Post#2656921    
    In response to gregjm25

I work Parts at a small Chevy dealer.We have replaced more than a few of these oil pumps,most of them on "auction cars".

'67 Camaro survivor
'06 Z71 Sierra Ex Cab
'37 Chevy cp.SOLD!!6/7/14
'74 Nova Custom cp.
'73 Nova pro-street project
'17 Chevy Trax LT
'00 S10 Ex cab






 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

1578 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.191 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 04:32 PM
Top