Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows





Username Post: losing power and difficulting shifting        (Topic#314315)
chel 
Forum Newbie
Posts: 1

Reg: 08-02-14
08-02-14 08:05 AM - Post#2473735    

I am having issues with 95 Camaro:
runs fine when cold
starts to warm up, loses power
Tach will got to 3 grand then start bogging
hard to shift when it gets warm.

Don't know if it is A problem or several.
Need information, please,
Chel



 
CowboyTrukr 
"9th Year" Silver Supporting Member
Posts: 4432
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
09-18-14 08:33 AM - Post#2484873    
    In response to chel

Welcome to ChevyTalk.

Let's start with a couple of useful bits of info:
Engine?
TBI or multiport?
Transmission?

Did it just start or has it gotten progressively worse?

Any work done on the car recently?

There are a couple of things that could be contributing, but let's get the answers to these questions first.

Greg

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD
‘87 GMC S15 SCLB 4.3 Auto - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

2253 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.165 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 06:14 PM
Top