Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Join the Community todayDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy





Username Post: Trans problems and more        (Topic#185076)
Donolie 
"8th Year" Gold Supporting Member
Posts: 269
Donolie
Loc: Detroit
Reg: 03-17-08
03-19-08 04:44 PM - Post#1392116    

Vehicle- 1989 Chevy


My first question would be about TQ converter. I swapped engines original(240k+)5.7tbi for another (possible gm create, unknown year) but it was out of a manual so I pulled the pilot bushing tried to put my org. flexplate on but it had diff bolt pattern. I went to local junkyard and found one that matched. (the engine crank looked externally balanced) after installing engine, the TQ converter made a ticking sound with inspection plate on, with it off, no sound was apparent, all bolts were tight. Could this be caused from wrong style converter or flex plate?


My second question is also regarding the transmission. one day of traveling down I-75 the trans suddenly started slipping and blew dipstick out and fluid all over engine compartment. I towed vehicle home and tried adding fluid but now it only has pressure within first 15 seconds of start up. Any Ideas?

Also rear Trans mount was rotted out and when in "park" on the column, trans is in reveres, maybe just adjust linkage?



Any help would be greatly appreciated.



Edited by Donolie on 03-19-08 04:47 PM. Reason for edit: No reason given.

 




txturbo 
Valued Contributor
Posts: 3547

Loc: Rosenberg,TX USA
Reg: 07-27-01
04-09-08 06:14 AM - Post#1407437    
    In response to Donolie

The ticking means something on the flexplate is hitting the cover. Look at the inside of the cover and see where its hitting, then you can tell what part of the flex plate is hitting it.
Normally the only reasons an automatic trans will spit out fluid is if it overheats,is overfilled or there is water in the fluid.Is the fluid a pinkish color? Sounds like you need to drop the pan and see what it looks like in there.You may have a plugged filter or the cooler lines or oil cooler are plugged.Did you flush out the cooler lines before hooking them up to the replacement transmission?

Dan
1969 Camaro SS 396/T400
1966 Impala 283/PG/AC
1966 Impala SS 427/4 Speed
1948 Panel 1 Ton
1963 Cadillac
1940 Ford P/U
1954 Chevy 3100
1955.2 Chevy 3100
1956 Cadillac CDV PINK
1930 Model A hot rod


 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

583 Views




FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.138 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 03:24 PM
Top