Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Nu-Relics Power Windows
American Auto Wire Hellwig Products IncPerformance Rod & Custom
Danchuk Catalog



Username Post: 1927 Chevy Truck Clutch
Dlelmp1579 
Newbie
Posts: 7

Reg: 07-23-18
04-10-21 07:53 AM - Post#2817794    

So, Finally got the 1927 Chevy Capital A to start consistently. However the brake light would also stay on once I pushed on the pedal. So it seemed to be an easy fix. I took the bar (brake rod from the pedal to the rear axel), off, cleaned it up and put it back - now the clutch is making noise when I press on it. When I took the Brake rod out, which is attached to the clutch pedal under the floor boards that is when the noise started w/the clutch. I am not sure if it is fine to drive like that or not.

I have adjusted the clutch pedal adjusting bolt and there is a noise (lite grinding) when the pedal is pressed. The clutch works - as I can shift it into all gears - but the noise is only there when I press the pedal, the noise stops when i let my foot off the pedal. It never made the noise before, just started when I disconnected the brake line to fix that.

Any easy suggestions? Thanks

dlelmp1579.blogspot.com - in this link are some pictures of the truck (along w/the dog). Thanks again for the help.

[image]https://dlelmp1579 .blogspot.com[/image]


NOTE: You are viewing an individual Post. View the Entire Topic
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.087 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 05:37 AM
Top