Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Join the Community todayDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

Ecklers AutoMotive
Username Post: 55 Sport Coupe - 396 LT1 - T56
WagonCrazy 
"12th Year" Platinum Supporting Member
Posts: 3174
WagonCrazy
Loc: So Cal
Reg: 06-07-05
07-06-19 08:41 AM - Post#2770045    
    In response to 2Loose

Thanks for the updates Willy.

You mentioned earlier:
  • Quote:
Got the hydraulic clutch bled and working, but the pedal feel is much
heavier than I think it should be, need to check that out...



I too am having a heavier-than-desired clutch pedal with the way I fabbed mine up in the Nomad. I need to get some pics and post them here to compare to yours, but I don't have any offset factor built into the rod mounting point. Just clevis around the pedal about 2 inches below the pedal pivot point. The clutch works fine (when driving it) but the pedal is hard like a truck and I need to re-fab up a way to reduce the amount of foot pressure on the pedal so it feels more like a modern car. Will post some pics of my setup soon, and ask for your advice. Take care, Paul.
57 Nomad -LS1 with C4 suspension
59 Apache Fleetside Shortbed BigWindow


NOTE: You are viewing an individual Post. View the Entire Topic
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.067 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 02:11 AM
Top