Gain extra benefits by becoming a Supporting Member Click here find out how!

Classic Performance Products Classic Industries
American Auto Wire
Danchuk Catalog
Hellwig Products IncPerformance Rod & CustomNu-Relics Power Windows



Username Post: 95 5.7 Tbi Suburban runs bad
95tbisuburban5.7 
Newbie
Posts: 7

Reg: 01-11-20
01-11-20 11:11 AM - Post#2784183    

Hi all,

I have a 1995 Suburban with a 5.7 and Tbi and for a while I have been chasing down a hesitation issue with little success. So far I have replaced spark plugs , wires , distrubuter cap and rotor , fuel filter and egr valve all withing the last 15000 miles. These changes maybe made a slight change to performance but it still hesistates bad. I have also pulled codes from it but no codes come up. I have also checked live data with the scan tool for the 02 sensors and all seems to be functional.The egr valve was not holding preassure too, so i changed that , but still not completely solved. Finally last week , i bought an adapter to test the fuel preassure at the TB and found that when its idleing it is around 9 psi and when i give it some gas underload (in gear) it drops to about 5-6. I know these early tbi systems run at low preassure but is this normal for it to drop that low ? Let me know your toughts. If not what would be your next steps ? Fuelpump? Regulator? Thank you all for your time. Anton
NOTE: You are viewing an individual Post. View the Entire Topic
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.152 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 02:54 PM
Top