Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
American Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: Water pump opening on block
PLS 
"7th Year" Silver Supporting Member
Posts: 1378
PLS
Loc: Smyrna, Georgia
Reg: 06-07-12
10-27-18 08:05 PM - Post#2749737    
    In response to 454cid

I want to thank you and bowtie44s for you help. I just got home and I checked the bolts by tracing the threads with a die and 3 are 3/8-16 X 2-1/8”. The 4th bolt wouldn’t even begin to start in the die. I check the heads and you are correct a 9/16 socket fits the three perfect as well as the 14mm. The 13mm fit the 4th bolt head good but the ½” socket was a tight fit and I believe as you said it is wrong and they must have picked up a bolt laying around and forced it in and thought that it was all the way in because of how tight it was. I was afraid that the threads would be damaged after you mentioned the bolt may have been a 10mm and was forced in but I tried one of the other bolts and it screws in just as easy as it does in any of the other holes. I already have the new gaskets and I think that I will just get new bolts as well.
The truck belonged to my neighbor and when he passed away in 2010 the family gave it to me. While he owned it, I replaced the pump for him and as I said in my original post I had it replaced again about 3 years ago because I didn’t have the time to do it myself. Thank you very very much for your help. Lamar


NOTE: You are viewing an individual Post. View the Entire Topic
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.076 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 11:11 AM
Top