Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: 1994 k-2500 brake switch        (Topic#349646)
islandpark60 
Forum Newbie
Posts: 19

Loc: Bluff City, TN
Reg: 12-27-09
02-13-18 02:04 PM - Post#2724284    

i have been having troubles with the transmission (1994 k-2500, 5.0l 4l60e 4wd) after replacing brake booster and it must have gone into limp mode (stuck in 2nd have 1st if manually shifted). Having been moving every wire under there to replace booster, figured I might upset some of the wires. I put a new brake switch on and a new tps. No change. I put my Actron scanner on it, which does do OBD1, No codes. Watched the live data and an odd thing shows up. One line says brake:ON. When you press the brake pedal it says brake:OFF.
Now I maybe not that bright, but that doesn't make sense. Line for 4wd says off and that is correct, so my thinking is something is not kosher.
Any ideas?



 
Low priced Genuine GM Auto Parts
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

65 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.192 seconds.   Total Queries: 16   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 11:13 PM
Top