Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

 Page 1 of 2 12
Username Post: Timing issues        (Topic#348923)
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-30-17 03:38 PM - Post#2719461    

I've got a problem that is totally beating me. I built a 383 stroker last winter. It's got 10.5 to 1 compression ratio. I run 93 octane fuel. I installed a cheap Chinese HEI distributor in it. I verified that the timings marks are true top dead center. For some reason i cannot advance the initial timing past 0 or it spark knocks like crazy. Even if it's at 2* it'll knock. The only thing i think it could be is that cheap distributor but i figured I'd ask before i spend $500 I a new MSD system.

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 




raycow 
Honored Member
Posts: 27078
raycow
Loc: San Francisco, CA
Reg: 11-26-02
12-30-17 03:59 PM - Post#2719464    
    In response to malibu27

What was wrong with your cheap GM HEI distributor that made you want to install a cheap Chinese distributor in order to fix?

If your spark knock is occurring under light throttle conditions, try disconnecting the vacuum advance line before you do anything else. If that doesn't make any improvement, it's very possible that putting some stiffer advance springs in your cheap Chinese distributor can solve your problem. Buy an advance kit and do some experimentation before you lay down $500.

Better yet, find a shop with a distributor machine and find out what your cheap Chinese distributor is doing now before you go inside it.

Ray

Those who choose an automatic transmission want transportation. Those who choose a manual transmission want to drive.


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-30-17 04:04 PM - Post#2719465    
    In response to malibu27

Some other helpful info is:
The motor is in a 1983 k20
Plug wires are MSD 8.5MM
Heads are Edelbrock Etec 170 64cc
Flattop pistons


'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-30-17 05:58 PM - Post#2719473    
    In response to raycow

the knocking does only occur under light acceleration. I'll try disconnecting the vac advance line and see what happens.

Are you saying that the MSD is a cheap chinese distributor? I've had the same cheap distributor in it the whole time.

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
Shepherd 
Frequent Contributor
Posts: 1034

Loc: Lake George, NY
Reg: 11-11-15
12-30-17 06:26 PM - Post#2719475    
    In response to malibu27

With a set back timing lite you can check the advance curve at any point. If the heads are steel, 10.5 compression is tough to control detonation unless you have an aggressive cam.



 
raycow 
Honored Member
Posts: 27078
raycow
Loc: San Francisco, CA
Reg: 11-26-02
12-30-17 11:14 PM - Post#2719497    
    In response to malibu27

  • malibu27 Said:
.....Are you saying that the MSD is a cheap chinese distributor? I've had the same cheap distributor in it the whole time.


Nope, I'm saying you should try to fix your cheap Chinese distributor's problems before laying down $500 for the MSD.

Ray

Those who choose an automatic transmission want transportation. Those who choose a manual transmission want to drive.


 
gchemist 
Senior Chevytalk Moderator
Posts: 24202
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
12-31-17 05:00 AM - Post#2719506    
    In response to raycow

What type of timing chain/gears are being used? Is the timing chain set advanced? Timing advanced gears are available for use.

'95 Jimmy SLT (Bought @131,814)
'83 Silverardo XST - ZZ4 powered
'96 GMC Jimmy LS Ret. @236651 miles


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-31-17 05:53 AM - Post#2719507    
    In response to Shepherd

  • Shepherd Said:
With a set back timing lite you can check the advance curve at any point. If the heads are steel, 10.5 compression is tough to control detonation unless you have an aggressive cam.



I do have a set back timing light. I'll check the advance throughout the curve. The heads are aluminum.

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-31-17 05:56 AM - Post#2719509    
    In response to gchemist

  • gchemist Said:
What type of timing chain/gears are being used? Is the timing chain set advanced? Timing advanced gears are available for use.



I installed a high quality Cloyes timing set to factory timing. Would it help to pull the crank gear off and install it on the advance keyway?

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-31-17 06:02 AM - Post#2719512    
    In response to malibu27

I forgot to mention that I did already install heavy springs in the distributor. It didn't seem to make a difference. I also custom ground the weights to try and get more advance out of it. I know you normally want around 34 degrees of total timing. Again, grinding the weights didn't seem to make a difference. I was able to get about 20 degrees of advance after I ground the weights.

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-31-17 06:34 AM - Post#2719515    
    In response to malibu27

I found the installation instructions for the Cloyes timing set. Looks like I could try advancing the cam timing to get better low end torque. I wonder how that would affect the spark knock?

http://www.cloyes.com/Images/Instruct/3%20k eyway%2...

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


Edited by malibu27 on 12-31-17 06:55 AM. Reason for edit: No reason given.

 
Shepherd 
Frequent Contributor
Posts: 1034

Loc: Lake George, NY
Reg: 11-11-15
12-31-17 08:41 AM - Post#2719522    
    In response to malibu27

Don't change anything til you correct the timing curve issue, I have set up engines like yours with 14 initial and 34 total at 3,000, with no issues, how did you determine piston tdc when checking the balancer to cover tdc mark?



 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-31-17 09:49 AM - Post#2719529    
    In response to Shepherd

I marked it when i built the engine. And i just checked it again with a scope camera yesterday and its still good.

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-31-17 11:52 AM - Post#2719541    
    In response to malibu27

Ok so i advanced the initial timing to 10* and that gave me 34* total timing at 3,000 rpm. I unhooked the vacuum advance from the carb and plugged the hole. Took the truck for a drive and it doesn't knock under light acceleration anymore. Does that mean somethings wrong with the distributor?

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
raycow 
Honored Member
Posts: 27078
raycow
Loc: San Francisco, CA
Reg: 11-26-02
12-31-17 01:56 PM - Post#2719552    
    In response to malibu27

Not necessarily defective, but more likely set wrong. Specifically, your total vacuum advance is either too much (in degrees) and/or is coming in at too low a vacuum value (in inches). You can do a rough check with a vacuum gauge and a timing light. However, it would be best to have this checked on a distributor machine like a Sun or whoever else makes them now.

Ray

Those who choose an automatic transmission want transportation. Those who choose a manual transmission want to drive.


 
Shepherd 
Frequent Contributor
Posts: 1034

Loc: Lake George, NY
Reg: 11-11-15
12-31-17 02:20 PM - Post#2719558    
    In response to raycow

Agreed, but if it runs strong, forget the vac advance for now.



 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
12-31-17 06:34 PM - Post#2719596    
    In response to Shepherd

Yes i will leave it unplugged. What does the vac advance do anyway? Better fuel mileage?

The motor does still ping under hard acceleration but that's because it's going lean. I've got a Innovate Motorsports AFR analog gauge, and a Holley 4150 double pumper. I just got the Holley, changed from an Edelbrock 1405. The Holley pretty much runs perfect out of the box except for hard acceleration. I've got a 50cc accelerator pump and bigger squirters on the way. I'm sure that'll remedy the problem.

Thanks for the help gentlemen

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
gchemist 
Senior Chevytalk Moderator
Posts: 24202
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
01-01-18 04:46 AM - Post#2719620    
    In response to malibu27

Moved over from the 73-87 Truck forum.

'95 Jimmy SLT (Bought @131,814)
'83 Silverardo XST - ZZ4 powered
'96 GMC Jimmy LS Ret. @236651 miles


 
grumpyvette 
Senior Chevytalk Moderator -- Performance Subject Matter Expert --
Posts: 17109
grumpyvette
Age: 69
Loc: FLORIDA USA
Reg: 03-16-01
01-01-18 06:57 AM - Post#2719631    
    In response to gchemist

you can,t fix a damn thing until you have verified facts and know what your dealing with
start by verifying tdc on the damper and timing tab reflect reality then map the timing curve

reading links may not be fun but it beats not having the car run decent by a long way

http://garage.grumpysperformance.com/index.php?thr...

http://garage.grumpysperformance.com/index.php?thr...

http://garage.grumpysperformance.com/index.php?thr...

http://garage.grumpysperformance.com/index.php?thr...

IF YOU CAN,T SMOKE THE TIRES AT WILL,FROM A 60 MPH ROLLING START YOUR ENGINE NEEDS MORE WORK!!"!
IF YOU CAN , YOU NEED BETTER TIRES AND YOUR SUSPENSION NEEDS MORE WORK!!


 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
01-01-18 07:19 AM - Post#2719633    
    In response to grumpyvette

Grumpy, appreciate the input. Maybe try reading the whole thread. I marked TDC when I built the motor. Then I checked it again with a Milwaukee scope camera through the spark plug hole 2 days ago. I made sure to check the basics before changing anything.

BTW I read all those articles BEFORE I built the motor. Thank you for helping with those. I really appreciate it.

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


Edited by malibu27 on 01-01-18 07:23 AM. Reason for edit: No reason given.

 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
01-01-18 07:27 AM - Post#2719635    
    In response to malibu27

I found this vacuum limiter from Crane. Anybody use one of these?

https://www.summitracing.com/parts/crn-99619-1

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
Shepherd 
Frequent Contributor
Posts: 1034

Loc: Lake George, NY
Reg: 11-11-15
01-01-18 07:43 AM - Post#2719638    
    In response to malibu27

Even with full vacuum at idle soon as you accelerate it would drop back the advance to close to zero, so pinging on acceleration should not be affected by the vacuum advance unless you have it connected to ported vacuum at the carb, instead of manifold vacuum.



 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
01-01-18 07:55 AM - Post#2719641    
    In response to Shepherd

I did have it connected at the carb before. Your saying if I connect the vac can to the manifold it might not ping on light acceleration?

The engine does have a high vacuum at idle. It's at 18 inches. When the pinging occured the eninge vacuum was usually around 10 to 15 inches. I have a full time vacuum gauge so I always know what it is.

'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


Edited by malibu27 on 01-01-18 08:00 AM. Reason for edit: No reason given.

 
IgnitionMan 
Valued Contributor
Posts: 3219

Reg: 04-15-05
01-01-18 08:20 AM - Post#2719642    
    In response to malibu27

Yes, that is the correct stand alone stop plate, but DO NOT mount it the way Crane says to, that will make things much worse. Crane p/n 99619-1

If you want a complete instructions and pictures package, ask for one, they get the vacuum advance fixed correctly.

Gmvacuumadvancemodificati ons@gmail.com

There is no charge for them, and you can run the correct full manifold vacuum without problems.

Since the stroke on a 383 is long, your 10 degrees is like 14 on a shorter stroke engine, so, you are in the right places for both initial and curve, but not for IDLE.

That engine would like 18 to 22 deg/BTDC @ IDLE, but it wouldn't like it all in initial degrees. So, how to get 10 initial, and, say, 20 idle?

Simple, set the vacuum advance degrees stop to give 10 degrees, and plug the vacuum advance into full manifold vacuum. Engine will start easily, idle timing will be where the engine wants to be, engine will run better.

You definitely want to use the vacuum advance, and need to do the mods before finish dialing the carb in.

I also advise NOT using the dial back feature on any and all non-computerized ignition systems. Add a timing tape, and leave the dial back OFF.

BTW, you mentioned aluminum heads, shoot for 192/195 deg/F. Coolant temp, not cooler. Aluminum heads dissipate heat more rapidly than cast iron, too cold an engine temp with them makes for problems not easily resolve, until the coolant/engine temp is brought up.



 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
01-01-18 01:43 PM - Post#2719700    
    In response to IgnitionMan

  • IgnitionMan Said:
Yes, that is the correct stand alone stop plate, but DO NOT mount it the way Crane says to, that will make things much worse. Crane p/n 99619-1

If you want a complete instructions and pictures package, ask for one, they get the vacuum advance fixed correctly.

Gmvacuumadvancemodificati ons@gmail.com

There is no charge for them, and you can run the correct full manifold vacuum without problems.

Since the stroke on a 383 is long, your 10 degrees is like 14 on a shorter stroke engine, so, you are in the right places for both initial and curve, but not for IDLE.

That engine would like 18 to 22 deg/BTDC @ IDLE, but it wouldn't like it all in initial degrees. So, how to get 10 initial, and, say, 20 idle?

Simple, set the vacuum advance degrees stop to give 10 degrees, and plug the vacuum advance into full manifold vacuum. Engine will start easily, idle timing will be where the engine wants to be, engine will run better.

You definitely want to use the vacuum advance, and need to do the mods before finish dialing the carb in.

I also advise NOT using the dial back feature on any and all non-computerized ignition systems. Add a timing tape, and leave the dial back OFF.

BTW, you mentioned aluminum heads, shoot for 192/195 deg/F. Coolant temp, not cooler. Aluminum heads dissipate heat more rapidly than cast iron, too cold an engine temp with them makes for problems not easily resolve, until the coolant/engine temp is brought up.



Great! Thanks for the info. My balancer is marked all the way out to 50 degrees so I don't have to use the dial back feature on my timing light.

My thermostat is a 180*. I had a 200* Tstat and the engine wanted to diesel when I turned it off. That may have been when I still had the PCV valve hooked up and it was pulling a TON of oil into the intake. I've since deleted the PCV. And the rings have since seated. I did a leak down test and all cylinders were at 2%.

I emailed those guys. Hopefully they get back with me on the modifications. Thanks a lot.

One other thing: I am getting some starter kick back only when the engine is warm. Is that a timing issue also?


'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


Edited by malibu27 on 01-01-18 01:45 PM. Reason for edit: No reason given.

 
IgnitionMan 
Valued Contributor
Posts: 3219

Reg: 04-15-05
01-01-18 04:56 PM - Post#2719719    
    In response to malibu27

"Those guys" WHO?

Dieseling can be from a lot of things, like not enough timing to allow the carb to idle the engine down, as you have now with no vacuum advance. Getting the vacuum advance set up correctly will help lower the idle speed by closing the carb down a bit, so it doesn't Diesel the engine, no matter the engine speed.

With hotter engines, incorrect idle speeds, incorrect timing/vacuum advance, and other factors, like carbs not tuned because of the other stuff, yup, idle quality can stink pretty bad.

When you get the vacuum advance and carb dialed, 195 deg/F. will work just dandy.

NO PCV system, NOT GOOD. Most people don't get this right very much, but there are a whole lot of different PC valves, in both vacuum level, and actual air volume flow, get just one of those parameters incorrect, makes for a really unhappy camper.

What specific idle rpms, and, if automatic, in and out of gear, please.



 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
01-01-18 06:41 PM - Post#2719727    
    In response to IgnitionMan

  • IgnitionMan Said:
"Those guys" WHO?

Dieseling can be from a lot of things, like not enough timing to allow the carb to idle the engine down, as you have now with no vacuum advance. Getting the vacuum advance set up correctly will help lower the idle speed by closing the carb down a bit, so it doesn't Diesel the engine, no matter the engine speed.

With hotter engines, incorrect idle speeds, incorrect timing/vacuum advance, and other factors, like carbs not tuned because of the other stuff, yup, idle quality can stink pretty bad.

When you get the vacuum advance and carb dialed, 195 deg/F. will work just dandy.

NO PCV system, NOT GOOD. Most people don't get this right very much, but there are a whole lot of different PC valves, in both vacuum level, and actual air volume flow, get just one of those parameters incorrect, makes for a really unhappy camper.

What specific idle rpms, and, if automatic, in and out of gear, please.



I emailed Dave the ignition guy. He emailed me right back with instructions on how to modify the vac advance.

The PCV system I had was absolutely draining my oil pan dry. I even tried a new PC valve and it still sucked oil through the intake. Now that the rings have seated I guess I could try it again. What happens with no PC valve? Which PC valve is a good one?

My truck idle's at 800 rpm. Manual transmission out of gear. Idle vacuum is 18 inches. Idle quality is very good. My AFR gauge reads 14 at idle.


'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
IgnitionMan 
Valued Contributor
Posts: 3219

Reg: 04-15-05
01-01-18 07:21 PM - Post#2719733    
    In response to malibu27

Just whom do you think "Dave the ignition guy" is?

Try "IgnitionMan". Why the special email for the vacuum advance info? Well, a whole lot of people that always recommend their pals for services in topics, got the impression I was "advertising" for my products, when that was the furthest thing from my intentions. As you can see in the info, that is purely to get the vacuum advance correct, no ads anywhere. So, I set up the pictures and instructions email to get the vacuum advance info out, without all the tearful crying, and false accusations.

Hope you take a close look at the info. Should help, it has for everyone that has done it.

Please outline the PCV system you had, valve from one valve cover to vacuum fitting on the carb, other side has a free open inlet hose, air filter base to valve cover, I hope. Because if there ISN'T an inlet for fresh air into the engine, the suction will suck the pan dry.

The keys are, the right valve spring tension for the PCV, and, the correct volume for the valve. Example: I have a 1972 Vega street car, 5 speed, nice rear end, power 4 wheel disk brakes, power/tilt steering, A/C, name it, its there. The engine was a 1963 200 horse all Aluminum Buick 215 V8, 300 aluminum heads, big valves, nice Crower cam, 300 Buick .600 stroker crank, Chevy rods, 305 Chevy pistons, all the good stuff.

That engine had a PCV system that used a 90 degree PC valve, with 16 inch vacuum to match the carb/engine vacuum. But, the volume of pulled air was too great, so, I made an aluminum slug for the vacuum line, with a 3/16ths hole, PCV worked well.

The new engine is a variation of the Buick, Rover 4.6 all aluminum, 300 heads, 300 stroker crank, a different Crower cam, Corvair big valves, welded heart shaped combustion chambers, 305 Chervy pistons, and, a full-on large air meter, 5.0 Mustang EFI nozzle tuned port EFI system that the stock Rover PC valve works nicely with. And, the entire engine still weighs 335 pounds.

What I do is figure out the specifics of the engine, and match up the PC valve I would use for the same scenario in my engine, and go from there. The valve I used in the 215 Buick was from a low horsepower 2bbl 390 FE Ford.

As far as AFR gauges, my take, serious useless, and I use the "read the plugs, look at the exhaust, feel the thing in the seat of your pants" gauge, and it works so much better than all that gauging that wants you to tune it to its whims, not what the engine tells me.

You see, the gauge may well dictate to run this setting, when common sense in the driver's seat screams another setting works better.

I just watched an old "Twilight Zone" with William Shatner. He had car troubles in a small town, and while it was being repaired, he went to eat, and started feeding a fortune telling machine. It got to the point he was feeding pennies into this machine as fast as he could throw them at it, and believing what it was telling him, instead of looking for himself, using his own common sense.

To myself, AFR gauges and dial back features on timing lights are much like that fortune telling machine, stick a penny in, blindly believe what it tells you, not what you can see with your own eyes, and feel with your butt.

Now, please, don't think I am insisting on you doing anything I say, you do as you wish. All I am here to do is help, you go forward from where you are, accept, reject, your choice.





 
malibu27 
Forum Newbie
Posts: 61
malibu27
Loc: Harrisonburg
Reg: 03-15-15
01-01-18 07:56 PM - Post#2719739    
    In response to IgnitionMan

  • IgnitionMan Said:
Just whom do you think "Dave the ignition guy" is?

Try "IgnitionMan". Why the special email for the vacuum advance info? Well, a whole lot of people that always recommend their pals for services in topics, got the impression I was "advertising" for my products, when that was the furthest thing from my intentions. As you can see in the info, that is purely to get the vacuum advance correct, no ads anywhere. So, I set up the pictures and instructions email to get the vacuum advance info out, without all the tearful crying, and false accusations.

Hope you take a close look at the info. Should help, it has for everyone that has done it.

Please outline the PCV system you had, valve from one valve cover to vacuum fitting on the carb, other side has a free open inlet hose, air filter base to valve cover, I hope. Because if there ISN'T an inlet for fresh air into the engine, the suction will suck the pan dry



Haha, I figured it was you but didn't want to imply. The PCV system I had was a cheap 90* PCV valve connected directly to the bottom of the carb. No vent on the other valve cover. Probably why it sucked the pan dry. The so-called professional mechanic that dyno-tuned the truck took the PCV valve off and vented the crankcase to atmosphere. I guess that's a no no.

I found this PCV valve. Although pretty pricy, what do you think? Necessary or not?

http://mewagner.com/?p=444


'83 chevy K20, 383, Scat Crank, Comp Cams 08-408-8, Etec 170's, sm465
'97 chevy 1500 Silverado, 350, 4L60E


 
IgnitionMan 
Valued Contributor
Posts: 3219

Reg: 04-15-05
01-02-18 07:35 AM - Post#2719765    
    In response to malibu27

No, actually, he probably helped the no fresh air into the PCV system without knowing why.

I'd redesign the system, work it out right, it does help the engine when done properly.

Nope on that valve, it only has a small proximity from one side of itself, to the other, needs suction on one side of the engine, fresh, clean ambient air inlet on the other side, full across the engine air path.

I didn't look, how much is that con job of a "valve"? Gotta be outrageous.



 




 Page 1 of 2 12
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

1059 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.277 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 12:01 AM
Top