Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy



Username Post: 1993 6.5l stalling        (Topic#348689)
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
12-13-17 08:09 PM - Post#2717864    

Hi all.
My 1993 K3500 6.5l TD keeps stalling when you let off the throttle.
Starts right back up. Runs like a champ.
Problem has been intermittent for a long time I have heard.
Yesterday it never stalled once, actually has not stalled on me in a few years. Forgot it had the issue.
today it stalled at least 20 times. Always when letting off the throttle.
Not knowing when it is going to happen kind of sucks when plowing and salting.
do the 6.5l Have a TPS? And what about a EGR?
I ask about the egr because It seems to be fine after it is fully warmed up.
Thanks all

Old School GM fan FOREVER


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
12-21-17 09:08 PM - Post#2718730    
    In response to rockfangd

nothing eh.
Nobody seems to remember anything with these 6.5s.
It is so weird. 2 days it did not stall, yesterday stalled a good 10 times

Old School GM fan FOREVER


 
CowboyTrukr 
"7th Year" Silver Supporting Member
Posts: 3908
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
12-22-17 01:10 AM - Post#2718737    
    In response to rockfangd

Didn’t Fritz have a coal burner? Anybody seen him on here in a while?


Edit. Just checked. Jeff (Fritz1990) hasn’t posted in over a year. Hope everything is well with him.

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
bowtie44s 
Valued Contributor
Posts: 3867
bowtie44s
Age: 35
Loc: wv
Reg: 08-29-12
12-22-17 08:39 AM - Post#2718764    
    In response to CowboyTrukr

  • CowboyTrukr Said:
Edit. Just checked. Jeff (Fritz1990) hasn’t posted in over a year. Hope everything is well with him.



Now, that you mention it, I haven't seen him post in a while either. Try sending him a private message. I get an email if someone sends me a PM.

Jeff

'88 Chevy K3500, aluminum head roller cam 511in³ stroker 10.5:1 compression, 96 NV 4500, 94-98 grille, 305/70-16 (33x12) BF Goodrich KM2s, 91 cluster swap


 
CowboyTrukr 
"7th Year" Silver Supporting Member
Posts: 3908
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
12-22-17 10:56 AM - Post#2718776    
    In response to bowtie44s

Rockfangd, forgive me if I recall incorrectly, but don’t the 6.5’s have two fuel pumps?

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
12-22-17 04:07 PM - Post#2718799    
    In response to CowboyTrukr

they have a transfer pump on the framerail and a injection pump in the center of the valley between the heads

Old School GM fan FOREVER


 
CowboyTrukr 
"7th Year" Silver Supporting Member
Posts: 3908
CowboyTrukr
Loc: Salt Lake City
Reg: 06-20-09
12-22-17 06:46 PM - Post#2718811    
    In response to rockfangd

That’s what I thought. I have no experience with the older GM diesels.

Greg

'95 K1500 Z71 EC Short Step 5.7L+0.040/NV3500
'00 Explorer XLT 4.0 V6 Auto
'94 K2500 5.7 NV4500 ECLB - SOLD

"The only thing necessary for evil to triumph is for good men to do nothing" Sir Edmund Burke


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
01-05-18 07:05 PM - Post#2720159    
    In response to CowboyTrukr

Ok so I have been doing a bit of research and dont have any great news.
The PMD(fuel driver) is the very likely culprit, except they did not start until 1994.
the injection pump is pretty different between 1993 and 1994.
So I need to find out what could fail on the 1993 that would cause the same issues. I am bummed. That thing kept shutting off but would start right back up. Very typical of a PMD failing

Old School GM fan FOREVER


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
01-21-18 09:22 PM - Post#2721704    
    In response to rockfangd

So I have a little update on this.
I removed the top of the injection pump and cleaned all I could see. I then filled the pump with powerservice diesel kleen. The silver bottle.
I then poured the rest into the fuel tank.
I hooked a hose up to the bleeder and ran it into a bottle for at least half a gallon.
I then took it out and pounded the snot out of it.
It is performing much better. Has more power. Knock on wood has not stalled once in over a week. Has not stalled once since I did what I did.
Also has not stalled on cold start like it usually did.
Fingers crossed.

Old School GM fan FOREVER


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
03-03-18 08:04 PM - Post#2726349    
    In response to rockfangd

So all was good til yesterday. Didn't stall once til then.
Problem came right back.
sometimes even slightly letting off the throttle it just shuts right off. It happens so fast. There is no chug or anything. Just bam and your coasting.
My main plow truck broke down yesterday and this truck is not a good main.
It must have stalled at least 25 times throughout the day. If I let it it would have shut off alot more.
So stumped. I purged over a gallon from the bleeder and made no difference

Old School GM fan FOREVER


 
runamukker 
Infrequent Contributer
Posts: 45

Reg: 01-01-18
03-04-18 10:26 AM - Post#2726401    
    In response to rockfangd

Older truck, older electrical = bad grounds sometimes.

Don't own a diesel truck though.

'92 K1500 Blazer Z71 350TBI 700R4 , 253,000 miles
'94 C1500 Cheyenne WT 350TBI 4L60e , 565,000 miles


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
03-04-18 11:50 AM - Post#2726409    
    In response to runamukker

hmm.
you do bring up a good point.
Considering it is a plow and a salter, not to mention all of the lights it has.
I put a high output alternator in it a few years back because it couldn't keep up under load and it has been good ever since. But that does not mean the engine may not have a flaky ground.
I might add that load has no affect on the stalling.
I will add 2 grounds tomorrow and will update.
Thank You

Old School GM fan FOREVER


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
03-05-18 08:16 PM - Post#2726580    
    In response to rockfangd

Checked and cleaned grounds good today. All seemed to be good.
both batteries ground to the engine and the body.
There are too many possibilities from
TPS to injection pump, timing, etc...
I am thinking that it is injection pump related for the fact that after did what I did to the pump it ran great for a month. But when it returned it is actually worse now than it was before

Old School GM fan FOREVER


 
Ryan53 
Infrequent Contributer
Posts: 41

Loc: South Dakota
Reg: 07-15-16
03-06-18 08:58 AM - Post#2726637    
    In response to rockfangd

Reading your thread I makes me think fuel issues, I have little experience with diesels except equipment maintenance. Our diesels were very sensitive to cold weather gelling up the filters and gas stations with questionable fuel.

1953 Chevy Belair 2dr sedan, 235/3speed 6volt
2000 (gmt400) K2500 CCSB 350/auto


 
rockfangd 
"5th Year" Gold Supporting Member
Posts: 2354
rockfangd
Age: 32
Loc: Utica ny
Reg: 04-13-10
03-16-18 09:21 PM - Post#2727894    
    In response to Ryan53

This truck is so weird.
Last 2 days it ran like new.
Omg, when it runs so good it is incredible.
As hard as I used it it never attempted to stall once
Happy but makes no sense.
Nothing was different than the days prior, temps, moisture, etc...

Old School GM fan FOREVER


 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

567 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.268 seconds.   Total Queries: 13   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 05:38 PM
Top