Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Nu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

Join the Community today







Username Post: No Power To TBI        (Topic#347072)
Deano94 
Forum Newbie
Posts: 2

Reg: 09-09-17
09-09-17 10:19 PM - Post#2707231    

Hello!

I have a 1991 Chevy G30 with the 5.7L 350 With throttle body injection.. I bought it from a guy in Oregon and it ran amazing, brought it home to Spokane Washington and drove it for a few days with absolutely no issues. One day while stopping by O Reillys to pick up a horn relay I got back in the Van and it would turn over but wouldn't start.

I've been struggling with this ever since. I replaced the fuel pump relay and fuel pump before realizing it wasn't getting power to the injectors. I went on to replace the throttle position sensor, ignition control module and the ECM. At first O Reilly's gave me the wrong ecm. when I plugged it in the injectors would flood the TB, it would start but run extremely rough and then die out and then the power to the Injectors would be cut again. I did not realize I had to swap the memory from the old ecm to the knew but once I learned of this I also learned it was the wrong ecm all together. So I went back to O Reilly's and got the ECM that matched perfectly with my old one, serial numbers and all and swapped the old memory into the new one. I thought for sure it would start but it is doing exactly what it was doing before. Turning over but not starting.. I am not a mechanic, but when I called a mechanic he came to the same conclusion as me, that it was the ECM... I am completely dumb founded. If anyone knowledgeable with the TBI that has had this problem could help me out It would be appreciated greatly..



 




acardon 
Ultra Senior Member
Posts: 10864
acardon
Loc: DFW TEXAS
Reg: 03-25-05
09-10-17 06:38 AM - Post#2707257    
    In response to Deano94

Are you getting spark to the plugs? The ECM has to see ignition pulses from the distributor before it will pulse an injector.

Don
66 Corvair (driving)
57 2dr HT (driving)
56 2dr HT (waiting to be restored)


 
Deano94 
Forum Newbie
Posts: 2

Reg: 09-09-17
09-10-17 09:47 AM - Post#2707283    
    In response to acardon

Spark and Fuel delivery were the first things I checked.



 




Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

421 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.253 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 11:08 PM
Top