Gain extra benefits by becoming a Supporting Member Click here find out how!
Classic Performance Products Classic Parts
Ciadella InteriorsAmerican Auto Wire Classic Industries
Chevs of the 40sDanchuk Catalog
Hellwig Products IncPerformance Rod & CustomEcklers AutoMotive
Octane LightingNu-Relics Power Windows
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

Username Post: Oil pressure GAUGE?        (Topic#343430)
56sedandelivery 
Dedicated Enthusiast
Posts: 5123
56sedandelivery
Age: 65
Loc: Everett, Wa.
Reg: 02-26-08
03-20-17 12:55 AM - Post#2682317    

My 82 Silverado recently needed a new battery. When I installed the new battery I noticed my oil pressure GAUGE was reading a little lower than it normally did. Just coincidence I thought, and have't really paid much attention to it. Tonight, I noticed it was reading about 15-20 on fire-up; usually it's about 30 (High pressure/high volume pump). Got on the freeway, and suddenly it went to "0", but no valve train noise or anything else, so I made the trip. No engine problems after the 120 mile round trip. Still reading "0", and I have't looked at the truck yet, I'll do that in the morning. What's the "MOST" likely case; cannister sending unit or the in dash gauge? I'm hoping sending unit.
I am Butch/56sedandelivery.




 
LMC Truck
gchemist 
Senior Chevytalk Moderator
Posts: 23968
gchemist
Loc: Austin, TX 78748
Reg: 05-09-00
03-20-17 03:50 AM - Post#2682325    
    In response to 56sedandelivery

Over time, sludge does build up inside the unit. Most likely the wire connection has corrosion on it. Check your engine to frame and battery to frame grounds.

'95 Jimmy SLT (Bought @131,814)
'83 Silverardo XST - ZZ4 powered
'96 GMC Jimmy LS Ret. @236651 miles


 
56sedandelivery 
Dedicated Enthusiast
Posts: 5123
56sedandelivery
Age: 65
Loc: Everett, Wa.
Reg: 02-26-08
03-20-17 09:43 PM - Post#2682507    
    In response to gchemist

I'll be ordering a sending unit. Thing was working when I left the house this morning, but before I got out of the neighborhood, it stopped and fell to "0" again. Course it has to be behind the mounting plate for the cruise control diaphragm.
I am Butch/56sedandelivery.




 
LMC Truck
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

251 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.564 seconds.   Total Queries: 17   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 03:39 AM
Top