40 Years of Service

Username Post: Brake pedal rebound problem.        (Topic#327630)
ACinSD 
Forum Newbie
Posts: 55
ACinSD
Age: 41
Loc: San Diego, CA
Reg: 04-25-09
08-15-15 11:12 PM - Post#2569050    

I installed a CPP power master cylinder with 8" booster. When the engine isn't running, pedal is nice and tight, has good rebound, zero issues. As soon as the engine is running and the brakes are applied, the pedal doesn't rebound. What would be causing this to happen? If I pop off the fitting on the booster you can hear it suck air and the pedal returns to normal. Apply pressure again while running and it's the same story, no rebound.

The engine is a 283 with original style 2 barrel intake. We used the rear port on top of the intake for our vacuum line connection.

Any ideas on what may be causing the pedal to stay to the ground and the booster not burping?




 
ACinSD 
Forum Newbie
Posts: 55
ACinSD
Age: 41
Loc: San Diego, CA
Reg: 04-25-09
08-17-15 07:39 AM - Post#2569334    
    In response to ACinSD

Rod length adjustment was the solution. It's was too long and preloading the master cylinder.



 
Chevelle 
ChevyTalk Social Media Manager
Posts: 843
Chevelle
Loc: San Clemente, CA
Reg: 08-31-13
08-18-15 04:27 PM - Post#2569675    
    In response to ACinSD

Thank you for providing the solution Ari. Hope it helps others.


Chevelle

Become a Supporting Member and we'll turn off the ads!!!


 
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

1455 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.22 seconds.   Total Queries: 12   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 10:50 AM
Top