Gain extra benefits by becoming a Supporting Member Click here find out how!
Silver
Gold ***Platinum***
deek01BigDogSS (6)jk56chevy (11)WarrenL (2)Jens (10)
edad2000Custom_Deluxe_20VetteGyrl (2)JohnB (2)
speedygman (7)rickityfiftyMafo971Clifford Lao502drfleetline
Jud Leowish Non-synchronized
gary635g (6)
johnhem (10)
axmaker (3)
socalarch (3)
usmile4 (8)
Classic Performance Products Classic Parts
Ciadella Interiors American Auto Wire Art Morrison.com
Exile® Battery Keeper™ 6/12 volt charger w/ LED battery monitor
Low priced Genuine GM Auto PartsHarbor Freight
Hellwig Products IncPerformance Rod & Custom
Impala Bob's Bob's Chevy Trucks Bob's Chevelle Parts Bob's Classic Chevy

Recent Hot Topics
Current Quote
"It only took me a day to realize i got really lucky finding the site and taking the time to sign up!"
~ New Member
Recent Topics
Join the Community today







Username Post: 89 Chevy Van G20 Won't run, no spark. Need help.        (Topic#268202)
Froadinman 
Forum Newbie
Posts: 2

Reg: 08-24-11
08-24-11 10:19 PM - Post#2129954    

I have a 1989 Chevy Van 20 (G20). Just yesterday I was driving down my street, stopped at the stop sign and it stalled as though out of gas. Tried to turn it back over with no luck.
I removed the dog house and the air filter housing, wanting to check if the injectors were shooting gas. The van briefly started and ran for about 10 seconds then stalled again and hasn't started again. The injectors are working. I did the old paper clip in the diagnostic port and got a 12 code for as long as the ignition was on acc.
Today I checked to see if I had a spark at the plugs, I didn't. Tried off the coil, there was no spark. I replaced the coil thinking that was it but still no spark or start. I still got a 12 code from the OBD.

 
Low priced Genuine GM Auto Parts
someotherguy 
Moderator
Posts: 25749
someotherguy
Age: 44
Loc: Texas
Reg: 08-01-03
08-25-11 06:16 AM - Post#2130027    
    In response to Froadinman

Welcome to the forum,

The main suspect is your ignition module in the distributor. Could also be the pickup coil, but the module is more likely. Check our FAQ post at the top of this forum listing for more info on "won't start."

Richard
94 C2500LD / 97 Suburban LS1 / 06 300C SRT8
Check out my truck shop projects


 
Smither 
Member
Posts: 407
Smither
Loc: Central Illinois
Reg: 12-26-02
08-25-11 10:23 AM - Post#2130084    
    In response to Froadinman

I 2nd the ignition module. Had almost same scenario on my '94 C1500. Was a bad module.
'94 C1500
'04 Crew Cab
'95 C1500 Suburban
'95 GMC K1500


 
OL55 
Contributor
Posts: 432
OL55
Reg: 01-01-08
08-25-11 07:21 PM - Post#2130271    
    In response to Smither

I had to do the module, then the pick up coil on my '89 van. Doesn't hurt to have an extra module if that is the case.

Larry

 
Froadinman 
Forum Newbie
Posts: 2

Reg: 08-24-11
08-25-11 10:41 PM - Post#2130349    
    In response to Smither

Thank you, both of you. Changed out the ignition module and it turned right over. I appreciate it!!! By the way I couldn't find the FAQ without actually looking it up in Google. I don't know if I'm blind or I just don't get the interface. This is a wonderful site!

 
someotherguy 
Moderator
Posts: 25749
someotherguy
Age: 44
Loc: Texas
Reg: 08-01-03
08-26-11 04:11 AM - Post#2130370    
    In response to Froadinman

Glad to hear you got it running and thanks for posting back with your results - it can help others reading in the future.

The FAQ is at the top of the 88-98 fullsize truck forum message list, titled "FAQ FREQUENTLY ASKED QUESTIONS / COMMON ISSUES"

Richard
94 C2500LD / 97 Suburban LS1 / 06 300C SRT8
Check out my truck shop projects


 
Low priced Genuine GM Auto Parts
Icon Legend Permissions Topic Options
Report Post

Quote Post

Quick Reply

Print Topic

Email Topic

3160 Views
FusionBB
FusionBB™ Version 2.1
©2003-2006 InteractivePHP, Inc.
Execution time: 0.1 seconds.   Total Queries: 15   Zlib Compression is on.
All times are (GMT -0800) Pacific. Current time is 02:27 AM
Top